[SOLVED]crazyflie 2.0 m1 and m4 lights solid red, m2 solid blue

Post here to get support
Post Reply
ben
Beginner
Posts: 20
Joined: Fri Jun 16, 2017 9:24 pm

[SOLVED]crazyflie 2.0 m1 and m4 lights solid red, m2 solid blue

Post by ben »

So I was trying to fix a problem with a crazyflie 2.0 and a z-ranger deck that I know works because I've tested it on other crazyflies, and i decided to use the cold boot and flash the firmware a few times to see if that would help. The first time I flashed the firmware the M2 light was solid blue, but i'd experienced that before so I held in the button BEFORE plugging in the battery, then released when it went into bootloader mode. I did this twice - it never restarted perfectly for me - and then the last time I did it the two front lights - M1 and M4 - went solid red, while the M2 light stayed solid blue. However, this time it can at least turn off, so there's that. Anybody have any ideas? in the meantime i'm going to try and flash the firmware again.

Edit: I'd like to clarify; this was a Crazyflie 2.0, and I was using the firmware version 2017.06. I know the crazyradio PA works because it's how I got the firmware on before I tried to flash it. I know the z-ranger deck works because i've used it on other crazyflie 2.0s before.
Last edited by ben on Wed Jul 05, 2017 6:22 pm, edited 1 time in total.
tobias
Bitcraze
Posts: 2041
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: crazyflie 2.0 m1 and m4 lights solid red, m2 solid blue

Post by tobias »

If the M1 and M2 goes on solid red it is a hard fault. Could be because of a badly flashed/wrong FW or a bug. Aren't you able to get the offical FW back on?
ben
Beginner
Posts: 20
Joined: Fri Jun 16, 2017 9:24 pm

Re: crazyflie 2.0 m1 and m4 lights solid red, m2 solid blue

Post by ben »

It went back into bootloader mode and after flashing it a few times it stopped.
arnaud
Bitcraze
Posts: 2302
Joined: Tue Feb 06, 2007 12:36 pm

Re: [SOLVED]crazyflie 2.0 m1 and m4 lights solid red, m2 solid blue

Post by arnaud »

Do you mean that it stopped not working? So it now works?
imranmomtaz
Beginner
Posts: 26
Joined: Tue Mar 17, 2020 7:01 pm

Re: [SOLVED]crazyflie 2.0 m1 and m4 lights solid red, m2 solid blue

Post by imranmomtaz »

ben and arnaud:
Hi, I am also facing the same problem. For reference, I am using CF2.1 and I downloaded proper FW from the github page https://github.com/bitcraze/crazyflie-firmware/. And

Please let me know the update of this event which you were discussing. Has this worked later?
Post Reply