Search found 17 matches

by Konstantin
Fri Jul 14, 2017 11:09 am
Forum: Developer Discussions
Topic: Understanding the Firmware
Replies: 13
Views: 3124

Re: Understanding the Firmware

Hey guys, I had the same connection-loss-problems like described in the first posts. I tried to change the datarate and channels, but the error occured somewhere else: If the Oracle VM VirtualBox is used to emulate the linux-system, it appears, that VM sets the USB-input to USB 2.0 as default. But m...
by Konstantin
Sun Oct 09, 2016 2:47 pm
Forum: Support
Topic: BigQuad - All fine, just M1 is lazy
Replies: 4
Views: 1609

Re: BigQuad - All fine, just M1 is lazy

Okay, i solved the problem! I noticed, that the soldered point on the CF board had an unstable/broken connection to the connector. I fixed it by soldering and now it's flying! Well, the PID values seems to need some adjustment, but hurray, it works!! :D
by Konstantin
Sat Oct 08, 2016 11:34 am
Forum: Support
Topic: BigQuad - All fine, just M1 is lazy
Replies: 4
Views: 1609

Re: BigQuad - All fine, just M1 is lazy

I had a closer look at the board and hit on something, showed in the red circle. Does these soldered point should be unused/free?
by Konstantin
Sat Oct 08, 2016 7:47 am
Forum: Support
Topic: BigQuad - All fine, just M1 is lazy
Replies: 4
Views: 1609

Re: BigQuad - All fine, just M1 is lazy

Here are the values given by the voltometer:

Seems like the values of the M1 connection doesn't change during startup..
by Konstantin
Sat Oct 08, 2016 12:34 am
Forum: Support
Topic: BigQuad - All fine, just M1 is lazy
Replies: 4
Views: 1609

BigQuad - All fine, just M1 is lazy

Hey Bitcraze-Team, The BigQuad Deck is absolutely fascinating! I bought some big parts and build a big copter (couldn't name it crazyflie anymore, it's rather Crazybird). Everything connected (cf without battery, bigquad attached and connected to the escs), firmware modified and flashed. Well, as I ...
by Konstantin
Thu Sep 29, 2016 1:53 pm
Forum: Support
Topic: Buzzerdeck not working
Replies: 7
Views: 2131

Re: Buzzerdeck not working

Thank you very much! I'll send a mail after finishing this post =) @marcus: I checked the pins and their contact to the board. These have a proper connection. But I got another idea to check the integrity of the buzzer: If I got that right, the 2 pins should be connected by the piezobuzzer. I checke...
by Konstantin
Wed Sep 28, 2016 10:09 am
Forum: Support
Topic: Buzzerdeck not working
Replies: 7
Views: 2131

Re: Buzzerdeck not working

Sure, here they are. I hope, everything important is shown.
by Konstantin
Tue Sep 27, 2016 12:27 pm
Forum: Support
Topic: Buzzerdeck not working
Replies: 7
Views: 2131

Re: Buzzerdeck not working

Hi, thx for the fast reply =) the console output is: DECK_INFO: Found 1 deck memory. DECK_CORE: 1 deck enumerated EEPROM: I2C connection [OK]. AK8963: Self test [OK]. SYS: Free heap: 12840 bytes Edit: The CF config is: CF with long pins, batteryholder on top, buzzer deck on bottom Edit2: With both d...
by Konstantin
Mon Sep 26, 2016 1:02 pm
Forum: Support
Topic: Buzzerdeck not working
Replies: 7
Views: 2131

Buzzerdeck not working

Greetings CF-Team, I just unpacked a new Buzzerdeck (from exptech), which arrived together with a new LED-ring. I installed both on my CF. The LED-ring does what it is supposed to do, but there is no reaction from the buzzer deck. I went through the "getting started with the buzzer deck" tutorial an...
by Konstantin
Sat Sep 10, 2016 10:08 pm
Forum: Developer Discussions
Topic: Situation Awareness - Free Fall Prevention
Replies: 12
Views: 3597

Re: Situation Awareness - Free Fall Prevention

Sure! The very problem was the implementation of the "High" variable by expressing it as a function. The thesis is, that this function triggered the timeout. The solution was kind of easy: I just modified the original function in position_estimator.c, in this configuration it spits out the "High" va...