Wifi connected, but no stream return.

Discussions about the AI-deck
Post Reply
raven
Beginner
Posts: 15
Joined: Thu Sep 24, 2020 1:57 pm
Contact:

Wifi connected, but no stream return.

Post by raven »

I flashed the NINA successfully and connected to the wifi hotpot of the AI-deck.
When I run the viewer.py, there is not image stream returned and showed in the interface.
(I haven't flashed the GAP8)
Image
Please ask that what problems might happen?
Thanks~
Make positive impact.
marcus
Bitcraze
Posts: 601
Joined: Mon Jan 28, 2013 7:02 pm
Location: Sweden
Contact:

Re: Wifi connected, but no stream return.

Post by marcus »

Hi!

Yeah, that should work. Did you start the streamer after the AI deck has booted up?
raven
Beginner
Posts: 15
Joined: Thu Sep 24, 2020 1:57 pm
Contact:

Re: Wifi connected, but no stream return.

Post by raven »

Yes. I restarted the Crazyflie(also means restarted the AI-deck) many times. The wifi hotpot is still there. But no stream returned using the example code.
Make positive impact.
kimberly
Bitcraze
Posts: 560
Joined: Fri Jul 06, 2018 11:13 am

Re: Wifi connected, but no stream return.

Post by kimberly »

Check the answer I gave in this forumthread: viewtopic.php?f=21&t=4491

It has something to do with the streamer not working in SDK 3.6 and up (see this issue). Make another docker image for gap8 for sdk version 3.5 and flash again. The LED of the gap8 should be blinking
kimberly
Bitcraze
Posts: 560
Joined: Fri Jul 06, 2018 11:13 am

Re: Wifi connected, but no stream return.

Post by kimberly »

woops sorry, I meant this thread:

viewtopic.php?f=21&t=4476&start=10

Anyway, does it work for you now?
raven
Beginner
Posts: 15
Joined: Thu Sep 24, 2020 1:57 pm
Contact:

Re: Wifi connected, but no stream return.

Post by raven »

Thanks!
I met an another problem while executing the last command in the https://github.com/bitcraze/AIdeck_exam ... er-gap8.md

It said that "Warn : Burst read timed out"
Make positive impact.
raven
Beginner
Posts: 15
Joined: Thu Sep 24, 2020 1:57 pm
Contact:

Re: Wifi connected, but no stream return.

Post by raven »

I found an interesting thing.
When I connect the ai-deck GAP8 debugger using the 10-20 pin adapter, the LED don't twink~
Make positive impact.
kimberly
Bitcraze
Posts: 560
Joined: Fri Jul 06, 2018 11:13 am

Re: Wifi connected, but no stream return.

Post by kimberly »

the warn burst time read out warning usually occurs when the programmer is not good connected. Just reconnect and connect again, remove it from your computer and reconnected there again and see if it works.

yes, the LED sometimes goes off since some debugger pull the reset pin right away. It should still be possible to program though if it is well connected.
raven
Beginner
Posts: 15
Joined: Thu Sep 24, 2020 1:57 pm
Contact:

Re: Wifi connected, but no stream return.

Post by raven »

Thanks!
I tried some times. Sometimes the "Burst read timed out" error will happen.
But sometimes, there is a new error
Image
Make positive impact.
kimberly
Bitcraze
Posts: 560
Joined: Fri Jul 06, 2018 11:13 am

Re: Wifi connected, but no stream return.

Post by kimberly »

Are you able to see the programmer if you write dmesg in the terminal (after you just connected)? And can you also copy past the exact line you put in the terminal to get this started.
Post Reply