Page 1 of 1

[Solved] [Too many packets lost] in state [1]

Posted: Thu Feb 19, 2015 8:51 am
by netzzi
i have trouble to get a raspberry pi headless working. i tested the crazyflie 2.0 with windows7 and the crazyradio together and all works fine (controled with a iphone6)
now i tried the rasperry pi image (0.3) form there: ... aspberrypi and can't get the radio working.
so i build my own and new build on my own like here ... aspberrypi from scratch with an new wheezy
if i try to connect to my crazyflie i got some error in the log or on the console:

Code: Select all

bitcraze@crazyflie ~ $ /home/bitcraze/projects/crazyflie-pc-client/bin/cfheadless -u `cat /home/bitcraze/link.conf` -i `cat /home/bitcraze/controller.conf`
Will use [Sony PLAYSTATION(R)3 Controller] for input
INFO:cflib.crazyflie:Callback->Connection initialized[radio://0/10/250K]
INFO:cflib.crazyflie:We are connected[radio://0/10/250K], request connection setup
WARNING:cflib.crazyflie:Got link error callback [Too many packets lost] in state [1]
INFO:cflib.crazyflie:Callback->Connected failed to [radio://0/10/250K]: Too many packets lost
Connection failed on radio://0/10/250K: Too many packets lost
bitcraze@crazyflie ~ $
the red led on the crazyradio blink one time after start the cfheadless, got the same error if the crazyflie on or off.
somebody here who can help me?

Re: [Too many packets lost] in state [1]

Posted: Thu Feb 19, 2015 10:17 am
by arnaud

This looks like the connection uri is wrong, are you sure your copter is currently configured on channel 10 with datarate 250k? If not you should change the content of the file /home/bitcraze/link.conf

Re: [Too many packets lost] in state [1]

Posted: Thu Feb 19, 2015 12:19 pm
by netzzi
Thanks, Problem solved. I go back to win7 and looked at the parameter, was channel 80. so i switched to 80 at linux and the connection ist etablished.