flow deck v2 error

Post here to get support
AriadnaR
Beginner
Posts: 12
Joined: Fri Jun 04, 2021 3:19 pm

flow deck v2 error

Post by AriadnaR »

Hello,
I have been using crazyflie and I noticed that it works perfectly without flow deck v2. When I attatch flow deck v2, crazyflie starts blinking five times red. I ordered another flow deck v2 and it happens the same thing. I have a multi-range in the top and I attached the flow deck in the bottom. I also made sure the arrows are facing the right way.

I am following this website: https://www.bitcraze.io/documentation/t ... ng-bundle/
kimberly
Bitcraze
Posts: 771
Joined: Fri Jul 06, 2018 11:13 am

Re: flow deck v2 error

Post by kimberly »

Hi!

Some questions to understand more about your situation:
- Are both your crazyflie and flowdeck completely new?
- Are the pins bended or not connecting fully in anyway?
- Could you see an error in the console tab in the cfclient ? (view/tabs/console)

For the last point, you need to connect the crazyflie by usb. Start the crazyflie up and immediately connect to the crazyflie through USB to get a readout.
AriadnaR
Beginner
Posts: 12
Joined: Fri Jun 04, 2021 3:19 pm

Re: flow deck v2 error

Post by AriadnaR »

yes they are both new.
They are both all the way through and the pins are leveled.
Attachments
Screenshot (2226).png
tobias
Bitcraze
Posts: 2152
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: flow deck v2 error

Post by tobias »

Looks like a problem with the Vl53L1 sensor on the Flow deck but it is unlikely that it is a problem on two Flow decks. Also the same sensors works on the Multiranger deck so no buss issue. I'm leaning towards a software error, possibly we have a bug on the master branch. Can you try with:
  • The latest release 2021.03
  • With only the Flow v2 deck mounted and see if you get the same error.
AriadnaR
Beginner
Posts: 12
Joined: Fri Jun 04, 2021 3:19 pm

Re: flow deck v2 error

Post by AriadnaR »

I attached an image with only the flow deck v2.
By latested release do you mean "bitcraze"? I went to this page https://github.com/bitcraze/bitcraze-vm/releases/ and downloaded 2021.04 .
Attachments
Screenshot (2227).png
AriadnaR
Beginner
Posts: 12
Joined: Fri Jun 04, 2021 3:19 pm

Re: flow deck v2 error

Post by AriadnaR »

hello,
I believe I found a similar post. Do you think I have the same problem as viewtopic.php?t=3218 .
If so is there a video of how to fix it? I am more of a visual learner.
AriadnaR
Beginner
Posts: 12
Joined: Fri Jun 04, 2021 3:19 pm

Re: flow deck v2 error

Post by AriadnaR »

I tried to pus the "tongues"' out and run it again but it is still failing.
kristoffer
Bitcraze
Posts: 510
Joined: Tue Jun 30, 2015 7:47 am

Re: flow deck v2 error

Post by kristoffer »

The latest release 2021.03
Tobias was referring to the latest release of the Crazyfle firmware (https://github.com/bitcraze/crazyflie-firmware/releases). It looks like you are using a later version compiled from source code and it would be interesting to see if the problem also exists with the 2021.03 to rule out software problems.

The easiest way to flash the 2021.03 version to your Crazyflie is to use the bootloader option in the python client, see https://www.bitcraze.io/documentation/r ... re-upgrade.
AriadnaR
Beginner
Posts: 12
Joined: Fri Jun 04, 2021 3:19 pm

Re: flow deck v2 error

Post by AriadnaR »

I took off the flow deck v2 and then did the update. Did I had to leave it on or was is suppose to be without decks?
I am still have some errors, but not as much as before.
Attachments
Screenshot (2241).png
AriadnaR
Beginner
Posts: 12
Joined: Fri Jun 04, 2021 3:19 pm

Re: flow deck v2 error

Post by AriadnaR »

Does anyone know what the problem could be?
Post Reply