Page 1 of 1

Highlevel swarm example; drones are not taking off

Posted: Wed Jul 31, 2019 8:30 pm
by Yoyasp

While checking if my old code is compatible with this new high level swarm example ( ... i noticed two strange things. I was hoping you could elaborate on that.

First when running a sequence with more than one drone some or all drones refuse to take off. After some commands they might "randomly" start by going to the latest position (usualy crashing while doing so because of the high rate of change in velocity).
Here's what i've tried without success:
Sending more than one take-off command, changing the step duration both up and down, sending more position commands, sending fewer position commands, sending land commands and then sending take-off commands.

All with no result.

What i also noticed is that if i run a sequence with one drone it works just fine, if i then do the same sequence with a different drone it also works fine. once both drones have run a single sequence i can run a sequence with both of them.
Its almost as if they need to be primed or something. When i reconnect with the drones they stay "primed", but when they reboot they are again not capable of taking off in groups.

The second issue i am having with the lighthouse decks is that de Crazyflie 2.0 seems to be performing much worse with the lighthouse deck than the 2.1. The 2.0 seems to be much more wobbly and especially in the Z-axis (height). Position fluctuates about 4-5 cm up and down. Is this related to the updated crazyflie, or is there a setting we need to tweak?

Looking forward to hearing from you,


Re: Highlevel swarm example; drones are not taking off

Posted: Fri Aug 02, 2019 7:07 am
by kimberly

The link in your post does not work, could you send it again?

Also what do you mean exactly with old code? Old firmware or old python lib? Have you tried everything as well with latest master?

That the lighthouse deck is not performing well is indeed something to look into. The new crazyflie 2.1 has an improved IMU, but the lighthouse itself is quite accurate. Are you flying with the latest crazyflie firmware and can you explain a bit more about your setup of the basestations?

Re: Highlevel swarm example; drones are not taking off

Posted: Tue Aug 06, 2019 10:46 am
by Yoyasp
Hi Kimberly,

By old code i mean code that i previously write without the highlevel functionality. All drones are updated to the latest version, and so are the Bitcraze repo's.

The link i send was to the new high-level swarm example: ...

Please note that my main problem is that if i run the example above with more than 1 drone, my drones won't take off.
The "bobbing" of the 2.0 drones is a issue that is less pressing.

Re: Highlevel swarm example; drones are not taking off

Posted: Tue Aug 06, 2019 11:07 am
by kimberly
Probably best to make a separate forum thread about the lighthouse decks and the CF2.0 to keep the issues separate.

Have you tried to include the following as in ... ?

Code: Select all