Page 1 of 1

crazyradio PA connect issue

Posted: Sat May 21, 2022 3:29 am
by llarotta
Hello dear bitcraze, I can't connect crazyflie to cfclient in the virtual machine, it stays stuck, I've already tried several versions of virtual machines and none of them work, I also tried to perform a flight test from the app, but it connects to the app but it doesn't fly, so what I did was perform the recovery firmware update starting in bootloader mode via usb connection and put version cf2-2022.03

also install the drivers in windows 10, as explained in this tutorial ... sbwindows/

however the problem continues. please help me, could it be that something was damaged from the drone or the radio?

This appears in the terminal when I try to connect:

INFO:__main__:Disabling STL printouts
INFO:cfclient.utils.input.inputreaders:Input readers: ['linuxjsdev', 'pysdl2']
INFO:cfclient.utils.input.inputreaders:Successfully initialized [linuxjsdev]
INFO:cfclient.utils.input.inputreaders:Could not initialize [pysdl2]: No SDL2 support on Linux
INFO:cfclient.utils.input.inputinterfaces:Found interfaces: ['leapmotion', 'wiimote', 'zmqpull']
INFO:cfclient.utils.input.inputinterfaces:Could not initialize [leapmotion]: Leap Motion library probably not installed (No module named 'leapsdk')
INFO:cfclient.utils.input.inputinterfaces:Could not initialize [wiimote]: Missing cwiid (wiimote) driver No module named 'cwiid'
INFO:cfclient.utils.config:Dist config read from /home/bitcraze/projects/crazyflie-clients-python/src/cfclient/configs/config.json
INFO:cfclient.utils.config:Config file read from [/home/bitcraze/.config/cfclient/config.json]
INFO:cfclient.utils.input.inputinterfaces:Could not initialize [zmqpull]: ZMQ input disabled in config file
INFO:cfclient.utils.zmq_led_driver:ZMQ led disabled in config file
INFO:cfclient.utils.zmq_param:ZMQ param disabled in config file
INFO:__main__:If startup fails because of "xcb", install dependency with `sudo apt install libxcb-xinerama0`.
INFO:cfclient.utils.input:Using device blacklist [(VirtualBox|VMware)]
INFO:cfclient.ui.tabs.QualisysTab:Switching Flight Mode to: FlightModeStates.DISCONNECTED
INFO:cflib.crtp.radiodriver:v0.53 dongle with serial N/A found
INFO:cflib.drivers.cfusb:Looking for devices....
INFO:cflib.crtp.prrtdriver:Initialized PRRT driver.
INFO:cflib.crazyflie:Callback->Connection initialized[radio://0/80/2M]
INFO:cflib.crazyflie:We are connected[radio://0/80/2M], request connection setup
INFO:cflib.crazyflie:Callback->Connected to [radio://0/80/2M]
INFO:cflib.crazyflie.platformservice:Protocol version: 5
INFO:cflib.crazyflie.toc:TOC for port [5] found in cache
INFO:cflib.crazyflie:Log TOC finished updating

Re: crazyradio PA connect issue

Posted: Mon May 23, 2022 6:43 am
by kimberly

We noticed that some were having performance issues with the VM, especially manifesting in the connection time with the Crazyradio. So that is why I added some extra performance enhancing tips for the VM here: ... ng-for-use

See if you can increase your RAM and CPU of your virtual box and see if it improves.

but if you don't manage to improve it... I use windows myself and the CFclient natively installed on it which works pretty good, so I would advise to just do that. You can follow these instructions for that.

Re: crazyradio PA connect issue

Posted: Mon May 23, 2022 3:08 pm
by llarotta
Hello Kimberly, thanks for answering, what version of windows do you recommend? And is it normal that it doesn't work with the cfclient app on my cell phone either? Thank you very much

Re: crazyradio PA connect issue

Posted: Tue May 24, 2022 7:49 am
by tobias
There is a chance it is hardware problem with the radio. It would be good if you could post the cfclient console output here. You can get this by connecting with the USB cable as well if the radio can't connect.

Re: crazyradio PA connect issue

Posted: Wed May 25, 2022 12:57 am
by llarotta
This is what I get in the console when the radio connection is blocked.

Re: crazyradio PA connect issue

Posted: Wed May 25, 2022 6:56 am
by kimberly
The error says that it can not find the crazyradio, which is quite clear fault. Have you selected the crazyradio usb device in your virtual machine, like this? It's device>USB>Bitcraze Crazyradio PA USB dongle (there should be a check there)
Screenshot 2022-05-25 085449.png

Re: crazyradio PA connect issue

Posted: Wed May 25, 2022 7:00 am
by tobias
Adding to that, I was referring to the cfclient console. If you don't get any output when connecting with radio you can try with USB. If you are using the VM don't forget to hand over the Crazyflie USB device to the VM.

Re: crazyradio PA connect issue

Posted: Wed Jun 01, 2022 5:26 pm
by llarotta
I already solved the problem, I had the flow deck and the lighthouse positioning deck connected at the same time, that caused it to not connect. Thank you very much.

Re: crazyradio PA connect issue

Posted: Thu Jun 02, 2022 8:10 am
by kimberly

Great that it solved it for you. I'm a bit worried that the lighthouse deck and flowdeck are compatible with each-other so this is still an issue I'm afraid.

Anyway, if you want to discuss further, please start a discussion here: as we will lock this forum right here starting next week.