Problems with Assisted modes

Discussions about quadcopters/multi-rotors
Post Reply
cfnewbie
Beginner
Posts: 4
Joined: Wed Jun 17, 2020 8:51 am

Problems with Assisted modes

Post by cfnewbie » Thu Jun 18, 2020 5:40 am

Hi,

i am flying my quadcopter with crazyflie bolt, it is equipped with optical and local positioning deck.
it works perfectly fine when operating in normal mode, however when i turned on position or height hold mode, one of the motor at random will stop spinning or increase to max thrust, resulting in flip of death.

i couldnt think of any problem causing this as everything is calibrated nicely before each flight. Please help, thank you!



tobias
Bitcraze
Posts: 2013
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: Problems with Assisted modes

Post by tobias » Thu Jun 18, 2020 8:27 am

My suspicion is that the velocity and position controllers are not tuned. Maybe this thread can help a bit.

cfnewbie
Beginner
Posts: 4
Joined: Wed Jun 17, 2020 8:51 am

Re: Problems with Assisted modes

Post by cfnewbie » Mon Jun 22, 2020 7:07 am

Thanks Tobias, tried to mess around with the PID values of position and velocity controller, but the problem seems to get worst.
I am new to the crazyflie platform, may i know is there a tutorial on how to tune the PIDs accurately?

tobias
Bitcraze
Posts: 2013
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: Problems with Assisted modes

Post by tobias » Mon Jun 22, 2020 11:36 am

Unfortunately not but the approach is very similar to other quadcopter PID tuning guides. Did you try with the same values as suggested in the thread? Your build is probably more powerful then the Crazyflie 2.1 values so most likely the values should be lower. Did you also change the Kalman estimator weight value as discussed in the thread? I guess you are using the Flow deck?

cfnewbie
Beginner
Posts: 4
Joined: Wed Jun 17, 2020 8:51 am

Re: Problems with Assisted modes

Post by cfnewbie » Tue Jun 23, 2020 2:19 am

my build is similar to that in the thread but with 3 inch prop and 3500kv motor. i changed the PID values according to the thread but not the kalman estimator weight. I guess the problem could be caused by the flow deck cause i was flying over a blank flooring. I will test it again once get back to the workshop.

cfnewbie
Beginner
Posts: 4
Joined: Wed Jun 17, 2020 8:51 am

Re: Problems with Assisted modes

Post by cfnewbie » Mon Jul 13, 2020 7:01 am

Update: After verifying flow deck reading and changing the velocity and position PID according the thread, problem solved. The drone is able to hold its position and altitude well. However, there is noticeable vibration when the drone is holding its position.

May i know which parameter can i tune to reduce the vibration? TIA.

kimberly
Bitcraze
Posts: 381
Joined: Fri Jul 06, 2018 11:13 am

Re: Problems with Assisted modes

Post by kimberly » Mon Jul 13, 2020 10:01 am

Hi!

Tobias is on a long break now so I will try to see what I can do.

You probably would need to tune the attitude PID parameters, which can be found here in the firmware. Not sure if the attitude-rate or attitude should be tuned but probably would be good to slightly lower the P gain there in general and see what happens.

Post Reply