install CFclient on ubuntu 14.04

Discussions about all things Bitcraze
Post Reply
BI_in_LA
Beginner
Posts: 1
Joined: Wed Nov 28, 2018 2:46 pm

install CFclient on ubuntu 14.04

Post by BI_in_LA » Wed Nov 28, 2018 3:12 pm

Hi,
I am new to ubuntu and I follow the instruction on https://github.com/bitcraze/crazyflie-clients-python to install cfclient
When I try to execute command :

Code: Select all

 pip3 install -e .
I encountered with this problem:

Obtaining file:///home/yuze/Desktop/crazyflie-clients-python-master
Running setup.py (path:/home/yuze/Desktop/crazyflie-clients-python-master/setup.py) egg_info for package from file:///home/yuze/Desktop/crazyflie-clients-python-master
Traceback (most recent call last):
File "<string>", line 17, in <module>
File "/home/yuze/Desktop/crazyflie-clients-python-master/setup.py", line 33, in <module>
raise "must use python 3.5 or greater"
TypeError: exceptions must derive from BaseException
Complete output from command python setup.py egg_info:
Traceback (most recent call last):

File "<string>", line 17, in <module>

File "/home/yuze/Desktop/crazyflie-clients-python-master/setup.py", line 33, in <module>

raise "must use python 3.5 or greater"

TypeError: exceptions must derive from BaseException


Can anyone help me with this? thanks.


I open setup.py and find this

Code: Select all

 if sys.version_info < (3, 5):
raise "must use python 3.5 or greater"
Does that means I need to do system upgrade ?

arnaud
Bitcraze
Posts: 1826
Joined: Tue Feb 06, 2007 12:36 pm

Re: install CFclient on ubuntu 14.04

Post by arnaud » Thu Nov 29, 2018 6:54 am

Yes, you need to upgrade do at least Ubuntu 16.04 that has Python 3.5. Are you using the Bitcraze VM?

Another solution is to come back to the latest release (the commit just before I added this test), this way you can work without updating Ubuntu, from the VM it would be done with these commands in the console:

Code: Select all

cd projects/crazyflie-clients-python/
git checkout 297bc356f4c93d5514
sudo pip3 install -e .
You just made me realize that the Bitcraze VM is now not compatible anymore with the client: we accepted a pull request recently that bumps the minimum python version to 3.5 around the release and that is why I added this check. I will get going and start working on a new VM using Ubuntu 18.04.

arnaud
Bitcraze
Posts: 1826
Joined: Tue Feb 06, 2007 12:36 pm

Re: install CFclient on ubuntu 14.04

Post by arnaud » Thu Dec 06, 2018 8:05 am

An update on that: I released a new VM running XUbuntu 18.04 that solves the problem of running the client in the VM: https://github.com/bitcraze/bitcraze-vm/releases

Post Reply