Problem when using flow deck

Discussions and questions about the Crazyflie Nano Quadcopter
Post Reply
zhanghaijason
Member
Posts: 41
Joined: Fri Jul 28, 2017 9:07 pm

Problem when using flow deck

Post by zhanghaijason » Wed Sep 19, 2018 5:01 am

Hell,
I am trying to use the flow deck. I have updated the firmware. But I came across two problems.
1. I used the win10 machine to do this. The lastest CF client was installed. Both CF and CFradio can be recognized. But I cannot connect to CF with the CF client. When I tried BOOTLOADER, it tells me could not find crazyradio PA dongle.
2. I tried another PC which was installed VM before. However latest CF client in windows was not boot. So I use VM. Fist I updated all projects with the icon on desktop. This time everything can be recognized in VM. However, when I try to select hover from assist mode, there is no such option. I switched to a Z deck, this time I can select height. I assume it is because the client was not updated. However, I am lost in the new client readme.file in linux. I didn't get how to install the new client in Linux(VM). If that is the case, could you detail the install command for me (How to do the install cfclient to run it from source)?
Thanks



zhanghaijason
Member
Posts: 41
Joined: Fri Jul 28, 2017 9:07 pm

Re: Problem when using flow deck

Post by zhanghaijason » Wed Sep 19, 2018 10:56 pm

For the second point. I figured out part of it. Why the CF client cannot start. It is because this PC is wind7. I downloaded the CF client which was released in 2017/06. Then I can start it. Finally I can see there is a hover option and successfully used it. But I am still confused how to make other methods work.
Thanks

arnaud
Bitcraze
Posts: 2080
Joined: Tue Feb 06, 2007 12:36 pm

Re: Problem when using flow deck

Post by arnaud » Mon Oct 08, 2018 10:13 am

Your windows problem looks like the USB driver was not installed for the radio. Did you install the driver using zadig as described there: https://wiki.bitcraze.io/misc:usbwindows?

zhanghaijason
Member
Posts: 41
Joined: Fri Jul 28, 2017 9:07 pm

Re: Problem when using flow deck

Post by zhanghaijason » Wed Jan 30, 2019 11:51 pm

arnaud wrote:
Mon Oct 08, 2018 10:13 am
Your windows problem looks like the USB driver was not installed for the radio. Did you install the driver using zadig as described there: https://wiki.bitcraze.io/misc:usbwindows?
Hi the usb can be recognized. I am wondering if there is available client in the Linux VM to use the flow deck. And is it possible to limit the speed when using the gamepad to control?

arnaud
Bitcraze
Posts: 2080
Joined: Tue Feb 06, 2007 12:36 pm

Re: Problem when using flow deck

Post by arnaud » Thu Jan 31, 2019 9:40 am

The client in the VM can be updated to the latest version that has support for hover-assisted-mode (ie. the flow deck mode).

The velocity is hardcoded to be limited to +/-1m/s max in X/Y. There is no configuration for it unfortunately but you can add a multiplier in the code where VX/VY is calculated to scale the velocity setpoint (data.roll/data.pitch are between -1 and 1): https://github.com/bitcraze/crazyflie-c ... #L457-L458

Post Reply