Crazyflie 2.0 stuck with only M2 LED on

Post here to get support
Post Reply
technoslab
Beginner
Posts: 1
Joined: Sun Sep 16, 2018 7:26 am

Crazyflie 2.0 stuck with only M2 LED on

Post by technoslab » Sun Sep 16, 2018 7:36 am

Hey,

My crazyflie 2.0 is unresponsive and these are the symptoms:

1. Does not go into self test mode.
2. Does not respond to power button with only battery plugged in.
3. Plugging in USB results in only M2 led being constantly lit.
4. Voltage between VCC/GND is ~3V with USB plugged in and 0V with battery.
5. Battery voltage is ~4V at battery and on board where battery cable is soldered.
6. I can't get into bootloader or DFU mode with battery and/or USB plugged in. Only symptom #3 happens.

This started happening randomly i.e. I was not flashing firmware or charging the battery or flying it. I just came home from work, tried to turn it on and it won't start. I did flash firmware 2018.1 using iOS client earlier in the day.

Also: I was able to get it to start again after a day (started on it's own when USB was plugged in) but the issue has returned and it won't start anymore and all symptoms mentioned above are back.

Any help would be appreciated.

tobias
Bitcraze
Posts: 1731
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: Crazyflie 2.0 stuck with only M2 LED on

Post by tobias » Mon Sep 17, 2018 1:58 pm

It sounds a bit like a badly flashed FW but as it didn't happen after flashing I'm not so sure. Anyway try this:

1. Unplug battery and USB so CF2 is totally powerless.
2. While holding down the power button connect USB or battery and release button when M2 starts to blink
3. Hopefully M3 starts to blink as well and you can flash the FW again.

If not send us an email to support(at)bitcraze.io and we will help you out.

Post Reply