Pyqt5 is installed but not recognize when running cfclient

Post here to get support
Post Reply
sdkfz
Beginner
Posts: 1
Joined: Fri Jul 28, 2017 4:07 pm

Pyqt5 is installed but not recognize when running cfclient

Post by sdkfz » Fri Jul 28, 2017 4:21 pm

Hello,

I just buy a MacBook air (os version: 10.12.5) and I got this problem while installing the cfclient. I followed all the instruction on project github page but this happen when I when to run it:

MacBook-Air-de-Guillaume:crazyflie-clients-python guillaumemaitre$ cfclient
CRITICAL:cfclient.gui:No PyQT5 installation found, exiting!
MacBook-Air-de-Guillaume:crazyflie-clients-python guillaumemaitre$ brew install pyqt5
Warning: pyqt 5.9_1 is already installed


look like pyqt5 is installed but when running cfclient like in the tutorial it doesn't find pyqt5.
This is an awesome drone and I would like to use it somewhere else than in my room with my desktop computer since I have de crazy PA :)

hope someone have a solution to my problem.

sincerely,
MG.

arnaud
Bitcraze
Posts: 1994
Joined: Tue Feb 06, 2007 12:36 pm

Re: Pyqt5 is installed but not recognize when running cfclient

Post by arnaud » Mon Jul 31, 2017 11:38 am

Hi,

Are you sure the client is installed with the same python as the pyqt5 package is installed?

To verify, you can type:

Code: Select all

 $ which python3
/usr/loca/bin/python3      # Python3 should be in /usr/local/...
 $ python3 -m cfclient.gui
 # Should launch the Crazyflie client ...

nanobot9000
Beginner
Posts: 26
Joined: Mon Apr 11, 2016 4:33 pm

Re: Pyqt5 is installed but not recognize when running cfclient

Post by nanobot9000 » Tue Nov 20, 2018 3:59 pm

Just installed following the instructions here: https://github.com/bitcraze/crazyflie-c ... /README.md

I am getting the same error and this when I try the recommendation:

Code: Select all

CRITICAL:cfclient.gui:No PyQT5 installation found, exiting!
Michael-Timkos-MacBook-Pro:~ michaeltimko$ which python3
/opt/local/bin/python3
Michael-Timkos-MacBook-Pro:~ michaeltimko$ python3 -m cfclient.gui
/opt/local/bin/python3: Error while finding spec for 'cfclient.gui' (<class 'ImportError'>: No module named 'cfclient')
Any other options to check?
Thanks!

arnaud
Bitcraze
Posts: 1994
Joined: Tue Feb 06, 2007 12:36 pm

Re: Pyqt5 is installed but not recognize when running cfclient

Post by arnaud » Wed Nov 21, 2018 8:02 am

This confirms that the client is not installed in your python3 environment.

How did you install Python3?
- If you installed it from python.org you can install the client with "pip3 install cfclient[qt5]" and install SDL2 manually from https://www.libsdl.org/download-2.0.php
- If you are using the homebrew method you can do "pip3 install cfclient" and install pyqt5 and sdl2 using the brew command

Post Reply