[SOLVED]M2 and M3 lights stuck on

Post here to get support
Post Reply
ben
Beginner
Posts: 20
Joined: Fri Jun 16, 2017 9:24 pm

[SOLVED]M2 and M3 lights stuck on

Post by ben » Mon Jun 19, 2017 5:14 pm

I had the error with my crazflie 2.0 where the M2 light is solid blue, and thought I had fixed it by following the steps in a previous thread I found and flashed the firmware by getting into bootloader mode. However, when I clicked restart in firmware mode the M2 light came back on full, joined by the M3 so that both were solid blue with no other lights flashing. It does turn off and on, but it just keeps the lights on and doesn't turn the motors and isn't recognized by the VM client. I'm using the latest version of the firmware and have tried re-flashing and using other versions but so far nothing has worked.
Last edited by ben on Wed Jun 21, 2017 4:48 pm, edited 1 time in total.

arnaud
Bitcraze
Posts: 1707
Joined: Tue Feb 06, 2007 12:36 pm

Re: M2 and M3 lights stuck on

Post by arnaud » Tue Jun 20, 2017 8:39 am

When scanning for Crazyflie do you see it in the client? Then if you connect to it can you see anything in the console tab?

ben
Beginner
Posts: 20
Joined: Fri Jun 16, 2017 9:24 pm

Re: M2 and M3 lights stuck on

Post by ben » Wed Jun 21, 2017 3:27 pm

The crazyflie is recognized by the client but it refuses to connect, not getting past the 'connecting' stage. The terminal is continually printing out 'resending for pattern(93, 5)', occasionally interrupted by 'Dongle reported ACK status == None.'
Edit: It finally stopped trying 10 minutes later and displayed the 'Failed to connect: Too many packets lost' message.

ben
Beginner
Posts: 20
Joined: Fri Jun 16, 2017 9:24 pm

Re: M2 and M3 lights stuck on

Post by ben » Wed Jun 21, 2017 4:48 pm

Update: I fixed it somehow by flashing the firmware ~10 times, and it worked the last time I tried it. So to anyone having this problem, flash the firmware until it fixes itself via magic.

Lombazombie
Beginner
Posts: 11
Joined: Sun Mar 25, 2018 12:37 am

Re: [SOLVED]M2 and M3 lights stuck on

Post by Lombazombie » Thu Jun 28, 2018 5:24 am

Getting the same issue, however can't connect through dongle or usb. So I can't flash it.

arnaud
Bitcraze
Posts: 1707
Joined: Tue Feb 06, 2007 12:36 pm

Re: [SOLVED]M2 and M3 lights stuck on

Post by arnaud » Mon Jul 02, 2018 7:37 am

@Lombazombie can you please create a new thread explaining your problem with a bit more details.

Lombazombie
Beginner
Posts: 11
Joined: Sun Mar 25, 2018 12:37 am

Re: [SOLVED]M2 and M3 lights stuck on

Post by Lombazombie » Sat Jul 07, 2018 7:39 am

Hey, I created a thread over here. Thank you!

viewtopic.php?f=5&t=3064

Post Reply