Crazyradio not enumerating on bus

Post here to get support
j5cbo
Beginner
Posts: 2
Joined: Fri May 03, 2013 3:02 am

Crazyradio not enumerating on bus

Post by j5cbo » Fri May 03, 2013 3:17 am

I got my Crazyflie today, and I'm running into some trouble getting the radio to work. When I plug it in to my Mac (I've tried two machines), the red and green lights both come on and stay on, but no device shows up on the bus. On a Linux box, the LEDs turn back off after half a second, and this shows up in dmesg:

[19727.480558] usb 5-1.1.2: new full-speed USB device number 6 using xhci_hcd
[19727.493471] usb 5-1.1.2: device descriptor read/8, error -75
[19727.606999] usb 5-1.1.2: device descriptor read/8, error -75
[19727.770726] usb 5-1.1.2: new full-speed USB device number 7 using xhci_hcd
[19727.783584] usb 5-1.1.2: device descriptor read/8, error -75
[19727.897158] usb 5-1.1.2: device descriptor read/8, error -75
[19728.059871] usb 5-1.1.2: new full-speed USB device number 8 using xhci_hcd
[19728.072626] usb 5-1.1.2: device descriptor read/8, error -75
[19728.186062] usb 5-1.1.2: device descriptor read/8, error -75
[19728.359000] usb 5-1.1.2: new full-speed USB device number 9 using xhci_hcd
[19728.371706] usb 5-1.1.2: device descriptor read/8, error -75
[19728.485206] usb 5-1.1.2: device descriptor read/8, error -75
[19728.585338] hub 5-1.1:1.0: unable to enumerate USB device on port 2

Is my radio broken? Anything else I could try to troubleshoot?



tobias
Bitcraze
Posts: 1914
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: Crazyradio not enumerating on bus

Post by tobias » Fri May 03, 2013 11:54 am

I'm not the expert on the Crazyradio (Arnaud is) but something is definitely wrong. If the LEDs go off I think it means that the nRF24LU1+ is at least partly working. If I recall correctly the LEDs will go off when it has been enumerated so there might be some hope not having to return it and having to wait for a new one.

arnaud
Bitcraze
Posts: 2209
Joined: Tue Feb 06, 2007 12:36 pm

Re: Crazyradio not enumerating on bus

Post by arnaud » Fri May 03, 2013 12:03 pm

If the LEDs does not go off it means that the dongle is not enumerated. I have not seen this problem on Mac previously.

For your Linux log it look like you connected the dongle to a USB3 port, we have seen problems with Linux and USB3. Could you try to connect it to an USB2 port? Do you have a Windows machine lying around to test?

j5cbo
Beginner
Posts: 2
Joined: Fri May 03, 2013 3:02 am

Re: Crazyradio not enumerating on bus

Post by j5cbo » Fri May 03, 2013 4:14 pm

Sure enough, it works on Linux when I connect it to a USB2 root port!

USB3 problems would also explain it not working on the Mac, since I was using a recent Macbook Pro with USB3.

Now to get a controller and learn to fly :)

arnaud
Bitcraze
Posts: 2209
Joined: Tue Feb 06, 2007 12:36 pm

Re: Crazyradio not enumerating on bus

Post by arnaud » Fri May 03, 2013 6:20 pm

Great!

This is actually a bug in the dongle that makes it unable to enumerate on USB3 controllers (at least on Linux and Mac). As we have had problems with USB3 and Linux I was wrongly assuming that it was a Linux problem and we avoided using the USB3 ports :roll:.

I found where the bug is and am pushing a fix. An update of the firmware will be published later. In the mean time the dongle should be plugged to USB2 ports.

refriedchicken
Beginner
Posts: 2
Joined: Wed May 08, 2013 12:39 am

Re: Crazyradio not enumerating on bus

Post by refriedchicken » Wed May 08, 2013 12:42 am

So, I don't have ready access to USB2 ports and can't use the radio right now. Looking at the repository I see there has been an update to close Issue #2 for USB3 enumeration. How can I go about getting the firmware updated on my dongle?

*** UPDATE ***
I got my hands on a RPi and tried to use that. I can see it showing up as Nordic just like in this thread: http://forum.bitcraze.se/viewtopic.php?f=8&t=102

However still no joy. It blinks the leds once and then goes dark. Running the client on the RPi doesn't show it available as a connection. What logs or anything can I send you to help troubleshoot this.

arnaud
Bitcraze
Posts: 2209
Joined: Tue Feb 06, 2007 12:36 pm

Re: Crazyradio not enumerating on bus

Post by arnaud » Wed May 08, 2013 5:13 am

refriedchicken wrote:So, I don't have ready access to USB2 ports and can't use the radio right now. Looking at the repository I see there has been an update to close Issue #2 for USB3 enumeration. How can I go about getting the firmware updated on my dongle?
The upgrade is in preparation and will arrive soon, sorry about the delay.
refriedchicken wrote: I got my hands on a RPi and tried to use that. I can see it showing up as Nordic just like in this thread: http://forum.bitcraze.se/viewtopic.php?f=8&t=102

However still no joy. It blinks the leds once and then goes dark. Running the client on the RPi doesn't show it available as a connection. What logs or anything can I send you to help troubleshoot this.
Have you tried to run the client as root (with sudo), by default normal users cannot access the USB peripheral.

refriedchicken
Beginner
Posts: 2
Joined: Wed May 08, 2013 12:39 am

Re: Crazyradio not enumerating on bus

Post by refriedchicken » Wed May 08, 2013 1:42 pm

arnaud wrote:Have you tried to run the client as root (with sudo), by default normal users cannot access the USB peripheral.
Yes I did try as root with no luck. I will probably just need to wait for the update then.

No sweat on the upgrade was just thinking of compiling and installing myself if the fix was already committed to the repository.

marcus
Bitcraze
Posts: 599
Joined: Mon Jan 28, 2013 7:02 pm
Location: Sweden
Contact:

Re: Crazyradio not enumerating on bus

Post by marcus » Wed May 08, 2013 2:55 pm

refriedchicken wrote: However still no joy. It blinks the leds once and then goes dark. Running the client on the RPi doesn't show it available as a connection. What logs or anything can I send you to help troubleshoot this.
When running the cfclient from the terminal there should be log messages printed. Could you post them?

As for running on the Pi have a look at these two threads, here and here.

Daniel
Beginner
Posts: 11
Joined: Tue Apr 30, 2013 9:38 am

Re: Crazyradio not enumerating on bus

Post by Daniel » Sat May 11, 2013 4:32 pm

Hello everyone,

I was wondering if the USB3 problem is solved already? If yes how can i update the firmware of the crazy radio when it is not ackknowledged by the system?

for your information i use a late macbook pro. The VM is running on parallels.
Right now both LED's on the Crazyradio are on and wont go out.

thanks for your help

greets

Daniel

Post Reply