[SOLVED] CFCLient won't start in the VM

Discussions about all things Bitcraze
Post Reply
cgpenguin
Member
Posts: 32
Joined: Wed Aug 05, 2020 3:49 pm

[SOLVED] CFCLient won't start in the VM

Post by cgpenguin »

I have freshly installed the VM. However, trying to run cfclient yields the following error:

Code: Select all

INFO:cfclient.gui:Disabling STL printouts
INFO:cfclient.utils.input.inputreaders:Input readers: ['linuxjsdev', 'pysdl2']
INFO:cfclient.utils.input.inputreaders:Successfully initialized [linuxjsdev]
INFO:cfclient.utils.input.inputreaders:Could not initialize [pysdl2]: No SDL2 support on Linux
INFO:cfclient.utils.input.inputinterfaces:Found interfaces: ['leapmotion', 'wiimote', 'zmqpull']
INFO:cfclient.utils.input.inputinterfaces:Could not initialize [leapmotion]: Leap Motion library probably not installed (No module named 'leapsdk')
INFO:cfclient.utils.input.inputinterfaces:Could not initialize [wiimote]: Missing cwiid (wiimote) driver No module named 'cwiid'
INFO:cfclient.utils.config:Dist config read from /home/bitcraze/projects/crazyflie-clients-python/src/cfclient/configs/config.json
INFO:cfclient.utils.input.inputinterfaces:Could not initialize [zmqpull]: ZMQ input disabled in config file
WARNING:cfclient.ui.widgets.plotwidget:PyQtGraph (or dependency) failed to import:
Traceback (most recent call last):
  File "/home/bitcraze/projects/crazyflie-clients-python/src/cfclient/ui/widgets/plotwidget.py", line 58, in <module>
    import pyqtgraph as pg
  File "/home/bitcraze/.local/lib/python3.6/site-packages/pyqtgraph/__init__.py", line 19, in <module>
    import numpy  ## pyqtgraph requires numpy
  File "/home/bitcraze/.local/lib/python3.6/site-packages/numpy/__init__.py", line 140, in <module>
    from . import core
  File "/home/bitcraze/.local/lib/python3.6/site-packages/numpy/core/__init__.py", line 68, in <module>
    raise ImportError(msg.format(path))
ImportError: Something is wrong with the numpy installation. While importing we detected an older version of numpy in ['/home/bitcraze/.local/lib/python3.6/site-packages/numpy']. One method of fixing this is to repeatedly uninstall numpy until none is found, then reinstall this version.

WARNING:cfclient.ui.tabs.locopositioning_tab:PyQtGraph (or dependency) failed to import:
Traceback (most recent call last):
  File "/home/bitcraze/projects/crazyflie-clients-python/src/cfclient/ui/tabs/locopositioning_tab.py", line 66, in <module>
    import pyqtgraph as pg
  File "/home/bitcraze/.local/lib/python3.6/site-packages/pyqtgraph/__init__.py", line 19, in <module>
    import numpy  ## pyqtgraph requires numpy
  File "/home/bitcraze/.local/lib/python3.6/site-packages/numpy/__init__.py", line 140, in <module>
    from . import core
  File "/home/bitcraze/.local/lib/python3.6/site-packages/numpy/core/__init__.py", line 68, in <module>
    raise ImportError(msg.format(path))
ImportError: Something is wrong with the numpy installation. While importing we detected an older version of numpy in ['/home/bitcraze/.local/lib/python3.6/site-packages/numpy']. One method of fixing this is to repeatedly uninstall numpy until none is found, then reinstall this version.

INFO:cfclient.utils.zmq_led_driver:ZMQ led disabled in config file
INFO:cfclient.utils.zmq_param:ZMQ param disabled in config file
INFO:cfclient.utils.input:Using device blacklist [(VirtualBox|VMware)]
INFO:cflib.crtp.radiodriver:v0.53 dongle with serial N/A found
Traceback (most recent call last):
  File "/home/bitcraze/.local/bin/cfclient", line 11, in <module>
    load_entry_point('cfclient', 'console_scripts', 'cfclient')()
  File "/home/bitcraze/projects/crazyflie-clients-python/src/cfclient/gui.py", line 189, in main
    main_window = MainUI()
  File "/home/bitcraze/projects/crazyflie-clients-python/src/cfclient/ui/main.py", line 266, in __init__
    tab = tabClass(self.tabs, cfclient.ui.pluginhelper)
  File "/home/bitcraze/projects/crazyflie-clients-python/src/cfclient/ui/tabs/locopositioning_tab.py", line 469, in __init__
    self._set_up_plots()
  File "/home/bitcraze/projects/crazyflie-clients-python/src/cfclient/ui/tabs/locopositioning_tab.py", line 496, in _set_up_plots
    self._plot_xy = PlotWrapper("Top view (X/Y)", "x", "y")
  File "/home/bitcraze/projects/crazyflie-clients-python/src/cfclient/ui/tabs/locopositioning_tab.py", line 152, in __init__
    self.widget = pg.PlotWidget(title=title, enableMenu=False)
NameError: name 'pg' is not defined
Traceback (most recent call last):
  File "/home/bitcraze/projects/crazyflie-clients-python/src/cfclient/ui/main.py", line 837, in scan
    self.interfaceFoundSignal.emit(cflib.crtp.scan_interfaces(address))
  File "/home/bitcraze/.local/lib/python3.6/site-packages/cflib/crtp/__init__.py", line 73, in scan_interfaces
    found = instance.scan_interface(address)
Qt has caught an exception thrown from an event handler. Throwing
exceptions from an event handler is not supported in Qt.
You must not let any exception whatsoever propagate through Qt code.
If that is not possible, in Qt 5 you must at least reimplement
QCoreApplication::notify() and catch all exceptions there.


(python3:2185): GLib-CRITICAL **: 14:18:30.538: g_source_unref_internal: assertion 'source != NULL' failed
What am I missing here?
cgpenguin
Member
Posts: 32
Joined: Wed Aug 05, 2020 3:49 pm

Re: CFCLient won't start in the VM

Post by cgpenguin »

Problem solved (had to uninstall numpy and reinstall it).
kimberly
Bitcraze
Posts: 560
Joined: Fri Jul 06, 2018 11:13 am

Re: CFCLient won't start in the VM

Post by kimberly »

Great! Thanks for lettings us know
Post Reply