Failed to take-off (STEM Ranging Bundle)

Post here to get support
Post Reply
gabeoh
Beginner
Posts: 5
Joined: Mon Jan 13, 2020 6:08 pm

Failed to take-off (STEM Ranging Bundle)

Post by gabeoh »

Hi,

I recently purchased STEM Ranging Bundle (Crazyflie 2.1, Flow deck v2, and Multi-ranger deck).

I set up the flow deck and the multi-ranger deck following getting started guide. I also updated the firmware to the latest one "firmware-cf2-2019.09.zip".

When I ran the Python scripts from the start guides, the propellers started to spinning, but the device failed to take off from the ground.


STEM ranging bundle
https://www.bitcraze.io/getting-started ... ng-bundle/

The execution terminates shortly after all propellers started spinning without taking off. The output below shows that the front, back, left, right, and up distances from multi_ranger are set to 0.

Connecting to radio://0/80/2M
Connected to radio://0/80/2M
Multi-ranger (front, back, left, right, up): None, None, None, None, None
Multi-ranger (front, back, left, right, up): None, None, None, None, None
Multi-ranger (front, back, left, right, up): 0.0, 0.0, 0.0, 0.0, 0.0
Demo terminated!


STEM drone bundle
https://www.bitcraze.io/getting-started ... ne-bundle/

The Crazyflie tries to perform missions (move forward, turn, roll etc.) but without taking off from the ground. 'stateEstimate.z' from logging shows that the z value stays around 79 (between 78.7 and 79.5).


Can anyone please help?

Thank you.
gabeoh
Beginner
Posts: 5
Joined: Mon Jan 13, 2020 6:08 pm

Re: Failed to take-off (STEM Ranging Bundle)

Post by gabeoh »

I'm still experiencing the problem with the Flow deck v2. At one point, stateEstimate.z value is reported as a negative value (around -40) and running the STEM drone bundle flight script shoot up the Crazyflie, hit the ceiling and broke one of the propellers.

While stateEstimate.z value stays at a similar level for multiple runs at the same period, the level is set to different ranges (-40, 75, 140 etc.) when tried at different times. The problem is that these values don't reflect the actual height of Crazyflie from the ground. Is any process required to calibrate the Flow deck? Could it be a defect of the sensor in the hardware?


Shown below are sample logs showing stateEstimate.z value of ~75.8.

[180472][Stabilizer]: {'stabilizer.roll': 1.2512367963790894, 'stabilizer.pitch': -5.6153788566589355, 'stabilizer.yaw': 44.35686111450195, 'stateEstimate.z': 75.85128784179688}
[180572][Stabilizer]: {'stabilizer.roll': 1.3461999893188477, 'stabilizer.pitch': -5.74921178817749, 'stabilizer.yaw': 44.38241195678711, 'stateEstimate.z': 75.84022521972656}
kimberly
Bitcraze
Posts: 521
Joined: Fri Jul 06, 2018 11:13 am

Re: Failed to take-off (STEM Ranging Bundle)

Post by kimberly »

Hi and sorry for the late reply!

There seem to be something wrong with your flowdeck, since these are not values that you are supposed to see.

If you connect to the cfclient with the crazyflie, could you see if your flowdeck is detected in the console output? Could you copy past the console output here in the forum thread?
gabeoh
Beginner
Posts: 5
Joined: Mon Jan 13, 2020 6:08 pm

Re: Failed to take-off (STEM Ranging Bundle)

Post by gabeoh »

Kimberly,

Thank you for looking into this. It does not seem that the console log includes flowdeck related details. Shown below is the console log when connecting to the Crazyflie device.


INFO:cflib.crazyflie:Callback->Connection initialized[radio://0/80/2M]
INFO:cflib.crazyflie:We are connected[radio://0/80/2M], request connection setup
INFO:cflib.crazyflie:Callback->Connected to [radio://0/80/2M]
INFO:cflib.crazyflie.platformservice:Procotol version: 4
INFO:cflib.crazyflie.toc:TOC for port [5] found in cache
INFO:cflib.crazyflie:Log TOC finished updating
INFO:cflib.crazyflie.mem:10 memories found
WARNING:cflib.crazyflie.mem:There is already a read operation ongoing for memory id 8
INFO:cflib.crazyflie:Memories finished updating
INFO:cflib.crazyflie.toc:TOC for port [2] found in cache
INFO:cflib.crazyflie:Param TOC finished updating
INFO:cflib.crazyflie:Callback->Connection setup finished [radio://0/80/2M]
INFO:cfclient.utils.logconfigreader:Parsing [stabilizer.json]
INFO:cfclient.ui.main:LED write done callback
INFO:cfclient.ui.tabs.LEDTab:Memory: id=1, type=LED driver, size=24
WARNING:cflib.crazyflie.mem:There is already a read operation ongoing for memory id 0
INFO:cfclient.ui.tabs.FlightTab:[imu_sensors.BMP388]: 0
INFO:cflib.crazyflie.log:Have successfully started logging for id=6
INFO:cfclient.ui.tabs.locopositioning_tab:Crazyflie connected to radio://0/80/2M
INFO:cfclient.ui.tabs.locopositioning_tab:Requesting loco deck parameter
INFO:cfclient.ui.tabs.FlightTab:[imu_sensors.HMC5883L]: 0
INFO:cflib.crazyflie.log:Have successfully started logging for id=8
INFO:cflib.crazyflie.log:Have successfully started logging for id=9
INFO:cflib.crazyflie.log:Have successfully started logging for id=10
INFO:cfclient.ui.tabs.FlightTab:[imu_sensors.MS5611]: 0
INFO:cfclient.ui.tabs.locopositioning_tab:No Loco deck installed
INFO:cfclient.ui.tabs.locopositioning_tab:No Loco deck installed
INFO:cfclient.ui.tabs.FlightTab:Changed effect to 0
kimberly
Bitcraze
Posts: 521
Joined: Fri Jul 06, 2018 11:13 am

Re: Failed to take-off (STEM Ranging Bundle)

Post by kimberly »

Hi!

This is the output of the terminal, but that is not the output that I meant. The console you can find in the cfclient as a tab 'Console'. If you don't see this, go from view>tabs and select console.
gabeoh
Beginner
Posts: 5
Joined: Mon Jan 13, 2020 6:08 pm

Re: Failed to take-off (STEM Ranging Bundle)

Post by gabeoh »

Hi Kimberly,

Shown below are console outputs from the Crazyflie Client; the first one is with Flow Deck only, and the second is with Flow Deck and Multi-Ranger Deck.

While the first output shows proper detection of the flow deck, the second output shows an error during deck detection. This also aligns with my observation that the device becomes uncontrollable when both decks are connected (by script or by XBox controller).


With Flow Deck v2 Only
---
SYS: Crazyflie 2.1 is up and running!
SYS: Build 140:2e5d259f68b3 (2019.09 +140) CLEAN
SYS: I am 0x20373357594B5008003D0038 and I have 1024KB of flash!
CFGBLK: v1, verification [OK]
DECK_CORE: 1 deck(s) found
DECK_CORE: Calling INIT on driver bcFlow2 for deck 0

ZR2: Z-down sensor [OK]
PMW: Motion chip id: 0x49:0xB6
IMU: BMI088 Gyro I2C connection [OK].
IMU: BMI088 Accel I2C connection [OK]
IMU: BMP388 I2C connection [OK]
ESTIMATOR: Using Kalman (2) estimator
CONTROLLER: Using PID (1) controller
MTR-DRV: Using brushed motor driver
EEPROM: I2C connection [OK].
DECK_CORE: Deck 0 test [OK].
STAB: Wait for sensor calibration...
SYS: Free heap: 5328 bytes
STAB: Ready to fly.


With Flow Deck v2 and Multi-Ranger Deck
---
SYS: Crazyflie 2.1 is up and running!
SYS: Build 140:2e5d259f68b3 (2019.09 +140) CLEAN
SYS: I am 0x20373357594B5008003D0038 and I have 1024KB of flash!
CFGBLK: v1, verification [OK]
DECK_INFO: Memory error: wrong header ID
DECK_INFO: Deck 1 has corrupt OW memory. No driver will be initialized!
DECK_CORE: 0 deck(s) found

IMU: BMI088 Gyro I2C connection [OK].
IMU: BMI088 Accel I2C connection [OK]
IMU: BMP388 I2C connection [OK]
ESTIMATOR: Using Complementary (1) estimator
CONTROLLER: Using PID (1) controller
MTR-DRV: Using brushed motor driver
EEPROM: I2C connection [OK].
STAB: Wait for sensor calibration...
SYS: Free heap: 8216 bytes
STAB: Ready to fly.
kristoffer
Bitcraze
Posts: 322
Joined: Tue Jun 30, 2015 7:47 am

Re: Failed to take-off (STEM Ranging Bundle)

Post by kristoffer »

Hi!
Unfortunately it seems as the Multi Ranger deck is broken, please contact us on support@bitcraze to resolve the problem.

- Kristoffer
tobias
Bitcraze
Posts: 2041
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: Failed to take-off (STEM Ranging Bundle)

Post by tobias »

Have you tried with just the multiranger deck attached? If you get the same memory error. You could also check the OW pin that it is contact to the deck with a ohm-meter. It is the 8th pin on the right side. See the expansion pins.
gabeoh
Beginner
Posts: 5
Joined: Mon Jan 13, 2020 6:08 pm

Re: Failed to take-off (STEM Ranging Bundle)

Post by gabeoh »

Hi Tobias,

I'm getting the same error even with only Multi-Ranger Deck is connected. The console log is attached below.

I'll proceed to the support team (support@bitcraze.io) as Kristoffer suggested.

Thank you.


With Multi-Ranger Deck Only
---
SYS: Crazyflie 2.1 is up and running!
SYS: Build 140:2e5d259f68b3 (2019.09 +140) CLEAN
SYS: I am 0x20373357594B5008003D0038 and I have 1024KB of flash!
CFGBLK: v1, verification [OK]
DECK_INFO: Memory error: wrong header ID
DECK_INFO: Deck 0 has corrupt OW memory. No driver will be initialized!
DECK_CORE: 0 deck(s) found

IMU: BMI088 Gyro I2C connection [OK].
IMU: BMI088 Accel I2C connection [OK]
IMU: BMP388 I2C connection [OK]
ESTIMATOR: Using Complementary (1) estimator
CONTROLLER: Using PID (1) controller
MTR-DRV: Using brushed motor driver
EEPROM: I2C connection [OK].
STAB: Wait for sensor calibration...
SYS: Free heap: 8216 bytes
STAB: Ready to fly.
Post Reply