Crazyradio used to work fine, now it doesn't even connect

Post here to get support
Post Reply
Posts: 1
Joined: Wed Feb 19, 2014 7:55 pm

Crazyradio used to work fine, now it doesn't even connect

Post by Mesfeir » Wed Feb 19, 2014 8:39 pm


I have a DOF 10 and i got the whole thing working yesterday on a keyboard controller, off of Ubuntu 12.04. Today the crazyradio suddenly decided to stop working for no apparent reason. Whatever is happening is really confusing because whenever I plug it into my USB2 the LEDS dont even flash, whenever I plug it into USB3.0 it flashes 4 times but I cant really locate it anywhere. I tried [lisusb] on Ubuntu and it doesnt show on the list anymore, when it was showing fine before. Same thing on my WIndows: doesnt even flash on USB2 and flashes on USB3, but i cant even locate it in Device Manager. I tried pluging into another computer, it flashed the first 2 times, but now it doesnt even flash on the other one . Lastly I tried to plug it into a third computer, and that one reads it as Unknown Device (tells me "Unknwon device is ready to use) of course I tried to install the drive using zadig but it didnt detect the Usb , and I tried downloading the driver and install it manually, and didnt work as well.

That began to happen around the time when I was trying to configure the Kinect to work on the crazyflie , i dont know if its related. I have a feeling that its something related to the firmware. Oh, one small detail, if i try to insert the usb slowly in usb2.0, halfway in, the usb flashes briefly if I move it a bit, but if I insert it normally nothing happens

Any help wouldbe much appreciated.... It's driving me crazy and I can't find anyone that slightly has anything in common with the issue


Posts: 2013
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: Crazyradio used to work fine, now it doesn't even connec

Post by tobias » Thu Feb 20, 2014 7:56 am

Could you inspect the USB connector solder-pads for any cracks. Sounds like a cracked/bad soldering somewhere. Also check the small diode marked D1 for any possible bad contact.

Post Reply