Unable to get Crazyradio PA to connect to Crazyflie

Post here to get support
Post Reply
Aurorans Solis
Posts: 1
Joined: Sun Dec 10, 2017 8:46 pm

Unable to get Crazyradio PA to connect to Crazyflie

Post by Aurorans Solis » Sun Dec 10, 2017 9:06 pm

I've been trying to set up my Crazyflie with the Crazyradio on my computer (Windows 10 OS), but for whatever reason I'm unable to get them to connect. I am able to use the bootloader to upload firmware to the Crazyflie, but after I do that I am unable to connect to it. If I click "Scan," in the client (the standalone or the client in a VM) the red LED on the Crazyradio turns on for a while before turning off again. The output for the client (VM and standalone) looks like this (with some variances, but finding devices and the part about the radio are the same):

Code: Select all

INFO:cfclient.gui:Disabling STL printouts
INFO:cfclient.utils.input.inputreaders:Input readers: ['linuxjsdev', 'pysdl2']
INFO:cfclient.utils.input.inputreaders:Could not initialize [linuxjsdev]: Only supported on Linux
INFO:cfclient.utils.input.inputreaders:Successfully initialized [pysdl2]
INFO:cfclient.utils.input.inputinterfaces:Found interfaces: ['leapmotion', 'wiimote', 'zmqpull']
INFO:cfclient.utils.input.inputinterfaces:Could not initialize [leapmotion]: Leap Motion library probably not installed (No module named 'leapsdk')
INFO:cfclient.utils.input.inputinterfaces:Could not initialize [wiimote]: Missing cwiid (wiimote) driver No module named 'cwiid'
INFO:cfclient.utils.config:Dist config read from C:\Program Files (x86)\Crazyflie client/configs/config.json
INFO:cfclient.utils.config:Config file read from [C:\Users\prima\AppData\Local\Bitcraze\cfclient/config.json]
INFO:cfclient.utils.input.inputinterfaces:Could not initialize [zmqpull]: ZMQ input disabled in config file
INFO:cfclient.utils.zmq_param:Biding ZMQ for parameters at tcp://*:1213
INFO:cfclient.utils.zmq_led_driver:Biding ZMQ for LED driverat tcp://*:1214
INFO:cfclient.utils.input:Using device blacklist [(VirtualBox|VMware)]
INFO:cfclient.ui.main:Auto reconnect enabled: True
INFO:cflib.crtp.radiodriver:v0.53 dongle with serial N/A found
INFO:cfclient.utils.input.inputreaders.pysdl2:Looking for devices
INFO:cfclient.utils.input.inputreaders.pysdl2:Found 1 devices
INFO:cfclient.utils.input:Selected MUX: Normal
INFO:cfclient.ui.main:Role of InterLink Elite is Device
INFO:cfclient.utils.input.mux:Adding device InterLink Elite to MUX Normal
INFO:cflib.drivers.cfusb:Looking for devices....
INFO:cflib.crtp.radiodriver:v0.53 dongle with serial N/A found
INFO:cflib.drivers.cfusb:Looking for devices....
I have manually updated the firmware on the radio and tried messing around with user permissions and other things in the VM, but all that's succeeded in doing is messing up how the VM interacts with the Crazyflie such that trying to flash firmware to it now guarantees corrupted firmware on the copter. Works fine in the standalone Windows client, though. On that topic, though - the last time I tried flashing firmware to the Flie via the VM I ended up with a problem such that the M2 light turned on when it restarted and it would not turn off until I unplugged the battery. Just out of curiosity, I tried looking at available devices in the Windows client and saw that there was a copter that I could connect to, despite the fact that its firmware was corrupted. After that, I managed to restart it in firmware mode and flashed firmware to it again from the standalone client, which fixed the firmware, but now there's no longer a Crazyflie for me to connect to. Any suggestions?

Posts: 1996
Joined: Tue Feb 06, 2007 12:36 pm

Re: Unable to get Crazyradio PA to connect to Crazyflie

Post by arnaud » Tue Jan 02, 2018 11:28 am


It sounds like your Crazyflie radio address has changed. To verify the radio address you can connect to the Crazyflie using an USB cable, you will then be able to change radio channel/datarate and address. The client will by default try to connect using the address 0xe7e7e7e7e7.

For your bootloader experience, there might have been lost packets resulting in data corruption during the flashing process. As you discovered the radio CPU is independent to the main CPU which is why you could still connect, and it is alyways possible to try again since the radio bootloader cannot erase itself.

Post Reply