[SOLVED] Connection Lost to radio

Post here to get support
Post Reply
TheHobbyGuy
Beginner
Posts: 4
Joined: Sat May 25, 2013 3:16 am

[SOLVED] Connection Lost to radio

Post by TheHobbyGuy » Sat May 25, 2013 3:40 am

I am the proud owner of two Crazyflies - only one has been built thus far. To my dismay I could not fly more that a few feet from the Crazyradio USB dongle without losing connection.
I tried all the options on the forums, I changed channels, I changed the Radio Bandwidth, and I tried various combinations of both. I even turned off the Wifi in the house and the laptop to be sure something was not overpowering the signal.

No luck. Then I decided to go back to basics. I had my son walk the Crazyfly around, just in the palm of his hand to see if the signal was lost in any specific locations. It was consistent that a few feet away in any direction it lost signal. I then removed the antenna from the USB dongle to see if anything would change, I expected the distance to be shorter. Actually the result was the same. Ah HA! It is a bad antenna. I grabbed the antenna from the other kit and the signal locked in at 100% even clear across my house in the other room. I also tried an antenna I have from another radio dongle and it worked just as well. If I return the original antenna the issue returns.

Long story, short - if you are having connectivity issues try a different antenna. I would lobby to say that in the WIKI instructions we should advise that before a first flight a radio range check should be performed. All one has to do is connect to the Crazyflie and with it in the palm of your hand walk around the far ends of the flying environment. If you lose connection you will hear the tone from your laptop, or have a friend watch the screen for signal strength. It may save you a an unexpected crash or two.

I hope this helps someone else who may come across a bad antenna.



arnaud
Bitcraze
Posts: 2120
Joined: Tue Feb 06, 2007 12:36 pm

Re: [SOLVED] Connection Lost to radio

Post by arnaud » Mon May 27, 2013 8:28 pm

Good findings! Thanks for the report and explanation.

Can you please open a support case at Seeedstudio about that issue to notify them about the problem? The antennas are not supposed to be the cheap kind so we where not expecting anything such as this.

I am adding this to the Wiki troubleshooting page.

TheHobbyGuy
Beginner
Posts: 4
Joined: Sat May 25, 2013 3:16 am

Re: [SOLVED] Connection Lost to radio

Post by TheHobbyGuy » Wed May 29, 2013 5:58 pm

Will do. Thanks, glad it helps.

adjavaherian
Beginner
Posts: 26
Joined: Fri May 22, 2015 4:18 am

Re: [SOLVED] Connection Lost to radio

Post by adjavaherian » Sun May 24, 2015 1:00 am

I might be having the same problem. Got my CF and CR last week. Signal is really bad. I removed the antenna and get about the same thing. Will try to find a replacement.

Post Reply