Z-Ranger deck not recognized in VM client

Post here to get support
ben
Beginner
Posts: 20
Joined: Fri Jun 16, 2017 9:24 pm

Z-Ranger deck not recognized in VM client

Post by ben » Mon Jun 19, 2017 4:22 pm

I can't use a z-ranger deck i bought on one of my crazyflies because the VM does not recognize the option to switch to height-hold mode. It greys out height-hold and only lets me choose between position hold and altitude hold. I have three other crazyflies that all work fine with the same firmware, dongle, etc. I have tried switching out batteries and motors and everthing. I only have one z-ranger deck so I know it works on the other three crazyflies.

tobias
Bitcraze
Posts: 1616
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: Z-Ranger deck not recognized in VM client

Post by tobias » Tue Jun 20, 2017 7:18 am

First thing I would check is that you have an up to date firmware as the functionality is only present in the FW 2017.04 and newer.

ben
Beginner
Posts: 20
Joined: Fri Jun 16, 2017 9:24 pm

Re: Z-Ranger deck not recognized in VM client

Post by ben » Wed Jun 21, 2017 3:23 pm

I have tried flashing both the 2017.04 and 2017.05 versions, neither of which worked.

ben
Beginner
Posts: 20
Joined: Fri Jun 16, 2017 9:24 pm

Re: Z-Ranger deck not recognized in VM client

Post by ben » Wed Jun 21, 2017 5:12 pm

Now in addition to not recognizing the z-ranger deck, it also doesn't receive commands from the gamepad at all EXCEPT for the 'altitude assist' command, which sets the throttle to 50% and can't be adjusted. It also doesn't recognize battery life or pitch/roll/yaw in the displays in the VM, so I don't know if the reason for this behavior is the battery dying.

arnaud
Bitcraze
Posts: 1341
Joined: Tue Feb 06, 2007 12:36 pm

Re: Z-Ranger deck not recognized in VM client

Post by arnaud » Thu Jun 22, 2017 9:03 am

Could you copy-paste the console output after connecting the crazylfie (you can get it in the client in the console tab). It shoud show if the deck has been detected and initialized.

The client is checking for which deck is installed to activate the height hold mode. If all is working correctly the height hold mode should be possible to choose.

ben
Beginner
Posts: 20
Joined: Fri Jun 16, 2017 9:24 pm

Re: Z-Ranger deck not recognized in VM client

Post by ben » Thu Jun 29, 2017 2:56 pm

Here is the output:

INFO:cflib.crazyflie:Callback->Connection initialized[radio://0/80/250K]
INFO:cflib.crazyflie:We are connected[radio://0/80/250K], request connection setup
INFO:cflib.crazyflie:Resending for pattern (93, 5)
INFO:cflib.crazyflie:Resending for pattern (93, 5)
INFO:cflib.crazyflie:Callback->Connected to [radio://0/80/250K]
INFO:cflib.crazyflie:Resending for pattern (93, 5)
INFO:cflib.crazyflie.toc:TOC for port [5] found in cache
INFO:cflib.crazyflie:Log TOC finished updating
INFO:cflib.crazyflie.mem:Requesting number of memories
INFO:cflib.crazyflie.mem:3 memories found
INFO:cflib.crazyflie.mem:Requesting first id
INFO:cflib.crazyflie.mem:Requesting information about memory 1
INFO:cflib.crazyflie.mem:Memory: id=1, type=LED driver, size=24
INFO:cflib.crazyflie.mem:Requesting information about memory 2
INFO:cflib.crazyflie.mem:Memory: id=2, type=Loco Positioning, size=5632
INFO:cflib.crazyflie.mem:Done getting all the memories, start reading the OWs
INFO:cflib.crazyflie:Memories finished updating
INFO:cflib.crazyflie.toc:TOC for port [2] found in cache
INFO:cflib.crazyflie:Param TOC finished updating
INFO:cflib.crazyflie:Callback->Connection setup finished [radio://0/80/250K]
INFO:cfclient.utils.logconfigreader:Parsing [stabilizer.json]
INFO:cflib.crazyflie.mem:Writing new chunk of 24bytes at 0x0
INFO:cflib.crazyflie.mem:Updating content of memory 0
INFO:cflib.crazyflie.mem:Requesting new chunk of 16bytes at 0x0
INFO:cfclient.ui.tabs.LEDTab:Memory: id=1, type=LED driver, size=24
INFO:cflib.crazyflie.mem:WRITE: Mem=1, addr=0x0, status=0x0
INFO:cflib.crazyflie.mem:This write request is done
INFO:cflib.crazyflie.mem:Write to LED driver done
INFO:cfclient.ui.main:LED write done callback
INFO:cflib.crazyflie.mem:READ: Mem=0, addr=0x0, status=0x0, data=(48, 120, 66, 67, 1, 80, 0, 0, 0, 0, 0, 0, 0, 0, 0, 231)
INFO:cflib.crazyflie.mem:READING: We are still interested in request for mem 0
INFO:cflib.crazyflie.mem:Got new data: bytearray(b'0xBC\x01P\x00\x00\x00\x00\x00\x00\x00\x00\x00\xe7')
INFO:cflib.crazyflie.mem:Requesting new chunk of 5bytes at 0x10
INFO:cflib.crazyflie.log:Have successfully started logging for id=23
INFO:cflib.crazyflie.mem:READ: Mem=0, addr=0x10, status=0x0, data=(231, 231, 231, 231, 1)
INFO:cflib.crazyflie.mem:READING: We are still interested in request for mem 0
INFO:cflib.crazyflie.mem:{'radio_address': 996028180455, 'version': 1, 'pitch_trim': 0.0, 'radio_channel': 80, 'radio_speed': 0, 'roll_trim': 0.0}
INFO:cflib.crazyflie.log:Have successfully started logging for id=25
INFO:cflib.crazyflie.log:Have successfully started logging for id=26
INFO:cfclient.ui.tabs.FlightTab:[imu_sensors.HMC5883L]: 1
INFO:cfclient.ui.tabs.FlightTab:[imu_sensors.MS5611]: 1
INFO:cflib.crazyflie.log:Have successfully started logging for id=27
INFO:cflib.crazyflie.log:Have successfully started logging for id=28
INFO:cfclient.ui.tabs.FlightTab:Changed effect to 0
INFO:cflib.crtp.radiodriver:Dongle reported ACK status == None


the Dongle reported ACK status == None messages went on until I disconnected so I cropped them out except for the first one.

arnaud
Bitcraze
Posts: 1341
Joined: Tue Feb 06, 2007 12:36 pm

Re: Z-Ranger deck not recognized in VM client

Post by arnaud » Fri Jun 30, 2017 7:46 am

I meant the console of the crazyflie. In the client you can click to "view/tabs/console" to see the Crazyflie console.

For reference when connecting the z-ranger deck I get:

Code: Select all

SYS: ----------------------------
SYS: Crazyflie 2.0 is up and running!
SYS: Build 21:ab6d531c7ca7 (2017.05-21) CLEAN
SYS: I am 0x... and I have 1024KB of flash!
CFGBLK: v1, verification [OK]
DECK_DRIVERS: Found 10 drivers
DECK_INFO: Found 1 deck memory.
DECK_CORE: 1 deck enumerated
MPU9250 I2C connection [OK].
AK8963 I2C connection [OK].
LPS25H I2C connection [OK].
ESTIMATOR: Using estimator 1
EEPROM: I2C connection [OK].
AK8963: Self test [OK].
DECK_CORE: Deck 0 test [OK].
SYS: Free heap: 18544 bytes

ben
Beginner
Posts: 20
Joined: Fri Jun 16, 2017 9:24 pm

Re: Z-Ranger deck not recognized in VM client

Post by ben » Fri Jun 30, 2017 5:36 pm

My bad, here you go

Code: Select all

SYS: Crazyflie 2.0 is up and running!
SYS: Build 0:c4148a09528e (2017.04) CLEAN
SYS: I am 0x37303638343551183E0054 and I have 1024KB of flash!
CFGBLK: v1, verification [OK]
MPU9250 I2C connection [OK].
AK8963 I2C connection [OK].
LPS25H I2C connection [OK].
DECK_DRIVERS: Found 9 drivers
DECK_INFO: Found 0 deck memory.
DECK_CORE: 0 deck enumerated
EEPROM: I2C connection [OK].
AK8963: Self test [OK].
SYS: Free heap: 10048 bytes

tobias
Bitcraze
Posts: 1616
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: Z-Ranger deck not recognized in VM client

Post by tobias » Mon Jul 03, 2017 9:29 am

Then my best guess is that there is a connection problem to the 1-wire memory in the deck. Can you try to check if there is anything strange with e.g. the connector in the pin marked OW in yellow in the pinout chart. Could be the the soldering of that pin or inside the connector. If it is inside, it is possible to bend them out, gently with a small needle.

ben
Beginner
Posts: 20
Joined: Fri Jun 16, 2017 9:24 pm

Re: Z-Ranger deck not recognized in VM client

Post by ben » Mon Jul 03, 2017 6:14 pm

....hmm. It seems to have fixed itself over the weekend when I wasn't working on it. Thank you for your advice, and i'll be sure to remember it if this problem ever crops back up.

Post Reply