Problem connecting to Crazyflie

Post here to get support
Post Reply
jsabaron
Beginner
Posts: 3
Joined: Fri Apr 24, 2015 11:00 pm

Problem connecting to Crazyflie

Post by jsabaron » Fri Apr 24, 2015 11:15 pm

I purchased the CrazyRadio PA for the Microcopter 2.0 and installed the PCClient on a Win7 computer. I followed the instructions to download the drivers using Zadig. It installed but when I engage the PCClient, nothing happens. I hit connect on the PCClient and then hit scan but nothing happens. The redlight comes on when I put the dongle in the computer USB slot but stops soon thereafter. Like others, when I check the USB driver, it says that the CrazyRadio PA Dongle is working. I noticed that the driver is stored in the folder: Universal Series Bus Drivers but I thought that it should be saved in a different location, something like libusb. Also, I saw some other posts that one needs to purchase a certificate to get the drive to work on Win7. If that's important, can someone please let me know how this is done? I wish this was much easier.

I am not experienced with the VM or Linux and don't know how to do anything beyond basic Windows functions. Any help would be appreciate as I'm trying to get the copter flying for a science fair project for my little girl.

Thanks...

Also, I read a post that suggested a bootloader cold start (I'm not sure what this is). However, I enter this file and hit cold start and I received a message that the program cannot find the Crazyradio Dongle. Any help would be appreciated.

Also, I was reviewing the log and it appears as though the system is connecting to something. However, the green LED on the dongle doesn't go on nor does the crazyflie come up when I scan for it.
"INFO:cflib.crazyflie:Callback->Connection initialized[]
:We are connected[], request connection setup
:Closing link
:Callback->Disonnected from []"

Does this mean that the dongle is working fine and there is a problem with the Crazyflie?



dave_t
Beginner
Posts: 4
Joined: Mon Apr 27, 2015 1:12 am

Re: Problem connecting to Crazyflie

Post by dave_t » Mon Apr 27, 2015 1:26 am

I have what appears to be the same problem, only I am on windows 8.1

Have followed all the instructions, dongle is in, zadig loaded and run, dongle appears on deviecs under the libsubK USB Devices.

When I run the controller it doesn't connect to the quadcopter. Doesn't see anything on the scan.

I can connect using my ipad so I can fly the crazyflie and I love it.

I just want to use the pc as you can do more with that.

When I plug the dongle in both red and green leds light up and then go out.

It shows as a working device in the device manager.

Is the dongle faulty? is there some diagnostic software that can test it out.

Please help.

Thanks
Dave

arnaud
Bitcraze
Posts: 2046
Joined: Tue Feb 06, 2007 12:36 pm

Re: Problem connecting to Crazyflie

Post by arnaud » Mon Apr 27, 2015 10:32 am

Hi,

@jsabaron Does both RED and GREEN Leds comes up when you connect your Crazyradio? Is it a Crazyradio PA and can you look in the windows device manager that it appears as a Crazyradio PA? The fact that it is scanning would indicate that the driver is well installed.

@dave_t Your radio seems to work. Do you see the client scanning?

To both of you, can you copy-paste the content of the client about box, in the debug tab. It gives info about the state of the radio.

/Arnaud

dave_t
Beginner
Posts: 4
Joined: Mon Apr 27, 2015 1:12 am

Re: Problem connecting to Crazyflie

Post by dave_t » Tue Apr 28, 2015 11:49 pm

Hi Arnaud,

No, nothing comes up with the scan. When I press the scan button, nothing seems to happen.

The CrazyradioPA is on my laptop at home, so will have to get the contents of the log for you tonight.

Regards
Dave

dave_t
Beginner
Posts: 4
Joined: Mon Apr 27, 2015 1:12 am

Re: Problem connecting to Crazyflie

Post by dave_t » Wed Apr 29, 2015 8:56 am

Hi Arnaud,

Here is the contents of the debug tab, plus a couple of images showing the radio presence, and the command window that comes up on starting the client.

Don't know what else to supply.


"Cfclient
Cfclient version: 2014.01.0
System: win32

Interface status
serial: None
radio: Cannot find a Crazyradio Dongle
udp: None

Crazyflie
Connected: None
Firmware: None
Sensors found
Sensors tests
"
Attachments
crazyradioPA dongle presence.JPG
snippit of the device manager showing the devices after inserting the radio dongle
crazyflie pc startup window.JPG
pc startup window on running the client pc, prior to the control window popping up.

jsabaron
Beginner
Posts: 3
Joined: Fri Apr 24, 2015 11:00 pm

Re: Problem connecting to Crazyflie

Post by jsabaron » Fri May 01, 2015 9:59 am

Hi. I downloaded the virtual machine and was able to connect and fly the Crazyflie using the PC Client in the VM so clearly the Dongle and radio on the Crazyflie are fine. Does the VM have its own drivers for the dongle or does it pull them from my PC?

I'd prefer to use the PC Client since I've had problems with stability with the VM. Any ideas on how to configure the Client to scan for the Crazyflie would be appreciated as it still is not working. Thanks.

jsabaron
Beginner
Posts: 3
Joined: Fri Apr 24, 2015 11:00 pm

Re: Problem connecting to Crazyflie

Post by jsabaron » Fri May 01, 2015 10:05 am

Arnaud,

My log is similar for the PC Client. IS there any way to point the PC Client to the Dongle driver?

Cfclient
Cfclient version: 2014.01.0
System: win32

Interface status
serial: None
radio: Cannot find a Crazyradio Dongle
udp: None

Crazyflie
Connected: None
Firmware: None
Sensors found
Sensors tests

dave_t
Beginner
Posts: 4
Joined: Mon Apr 27, 2015 1:12 am

Re: Problem connecting to Crazyflie

Post by dave_t » Sun May 03, 2015 9:43 pm

Hi Jsabaron,

I haven't seen any details about the VM stuff.

do you have a web address that I can look for the details for setting it up? I haven't seen anything when looking for the crazyradiopa set up. And since you are getting the same symptoms as me, but sort of able to get the crazflie going from the pc, I would like to try setting up the VM and see if I can get it working for me, while Arnaud et al sort out what the poblem is with the PC client.

Thanks
Dave

chad
Expert
Posts: 555
Joined: Sun Sep 28, 2014 12:54 am
Location: New York, USA
Contact:

Re: Problem connecting to Crazyflie

Post by chad » Mon May 04, 2015 2:40 pm

dave_t wrote:do you have a web address that I can look for the details for setting it up? [...] I would like to try setting up the VM and see if I can get it working for me
Here is a tutorial for the VM in VMware on Win 7. Here is the main VM info page on the wiki.
Crazyflier - my CF journal...
4x Crazyflie Nano (1.0) 10-DOF + NeoPixel Ring mod.
3x Crazyflie 2.0 + Qi Charger and LED Decks.
Raspberry Pi Ground Control.
Mac OS X Dev Environment.
Walkera Devo7e, ESky ET6I, PS3 and iOS Controllers.

Post Reply