[SOLVED] Bug in Qt5 QtWebEngine?

Post here to get support
Post Reply
Mitteau
Expert
Posts: 199
Joined: Fri Jan 29, 2016 6:00 am

[SOLVED] Bug in Qt5 QtWebEngine?

Post by Mitteau » Thu Sep 21, 2017 1:26 pm

Hi
Still working on GPS for crazyflie. As I ported Python client to Qt.5 (Qt5.9), I need to modify GpsTab. But I get the following error message:"[6589:6615:0916/230154.301139:ERROR:nss_util.cc(808)] After loading Root Certs, loaded==false: NSS error code: -8018". Following"https://github.com/paritytech/parity/issues/6530", it looks that Chromium version of Qt has a BUG... Sad.
Jean-Claude
Last edited by Mitteau on Sun Sep 24, 2017 2:48 pm, edited 1 time in total.

Mitteau
Expert
Posts: 199
Joined: Fri Jan 29, 2016 6:00 am

Re: Bug in Qt5 QtWebEngine?

Post by Mitteau » Fri Sep 22, 2017 9:06 am

Hi
I isolated the erroneous line in GpsTab/pyqt5:
"self.map_layout.addWidget(self.view)"
where "self.map_layout" is a layout of the tab and "self.view" is defined:
"self.view = QtWebEngineWidgets.QWebEngineView()".
I did not forget to import:
"from PyQt5 import QtWebEngine
from PyQt5 import QtWebEngineWidgets".
What's wrong?
Jean-Claude

Mitteau
Expert
Posts: 199
Joined: Fri Jan 29, 2016 6:00 am

Re: Bug in Qt5 QtWebEngine?

Post by Mitteau » Sun Sep 24, 2017 2:48 pm

Hi
No problem since this error do not stop the software.
Apologize, but there is a bug somewhere.
Jean-Claude

arnaud
Bitcraze
Posts: 1291
Joined: Tue Feb 06, 2007 12:36 pm

Re: [SOLVED] Bug in Qt5 QtWebEngine?

Post by arnaud » Mon Sep 25, 2017 12:08 pm

So, it is just warning and the tab is working fine anyway?

Mitteau
Expert
Posts: 199
Joined: Fri Jan 29, 2016 6:00 am

Re: [SOLVED] Bug in Qt5 QtWebEngine?

Post by Mitteau » Mon Sep 25, 2017 1:54 pm

It looks so, but I have to make complete tests with a real machine. Something like viewtopic.php?f=6&t=2580#p13018, perhaps.
Jean-claude

Post Reply