Crazyflie dropps connection with "too many packages lost"

Post here to get support
Posts: 2
Joined: Sun May 14, 2017 9:32 pm

Crazyflie dropps connection with "too many packages lost"

Postby eeppii » Sun May 14, 2017 9:56 pm

Hi there!

I have a crazyflie2.0 and crazyradio PA. Just received them a few days ago and started facing the problems, which are described below, already at the very beginning.

I keep losing the connection to my crazyflie2.0 each time after a few seconds after the connection is established. Usually the error "too many packages lost" is thrown.
It usually takes several trials even to connect to the crazyflie. The connection search sometimes does not recognize any available channels.

I tried the following ways:
-connect through all different available channels to the crazyflie -> always the same behaviour: no connection or dropping it after a few seconds.
-tried it having the crazyflie close to the crazyradio PA -> no changes
-tried to run the VM on Ubuntu14.04, Windows 7 and Windows 10. Always the same behaviour.
-Bootloaded the latest firmware on the crazyflie -> no changes
-Run the Android App: First established the connection nicely a few times (2-3) and then started to show the same behaviour - losing control after a few seconds or not being able to connect. But overall the Android App is more stable than through crazyradio PA.
-Run the crazyflie client on Ubuntu14.04 itself, no changes in behaviour.
-Run the example code. Same behaviour: Losing connection After a few seconds or doesn't even connect.

Further information:
-After connection to the crazyflie (if succeeded) the telemetry data form the IMU ist in most (90%) cases not sent - or at least not shown in the GUI. It does read initially the parameters from the crazyflie (I can see them in the list on the gui) - but no further data is received and no further data is sent, e.g. control signals from my PS3 controller.
-If telemetry data is sent and shown on the gui - it's not updating smoothly but jerking.
-There is only 1 Wifi around in my testarea, switching this off did not make any difference.
-Self-test of crazyflie works fine.
-Never crashed the crazyflie, cant find defects by visual inspection.

Any help is greatly appreciated. Currently don't know how to proceed.

Posts: 1449
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: Crazyflie dropps connection with "too many packages lost"

Postby tobias » Mon May 15, 2017 9:12 am


Sounds a lot like something is defective with the radio on the CF2. Did you also try changing the datarate to 2Mbit?

Most likely you will need a replacement board. Can you please send us an email to if the 2Mbit change didn't work out.

Posts: 2
Joined: Sun May 14, 2017 9:32 pm

Re: Crazyflie dropps connection with "too many packages lost"

Postby eeppii » Sun May 21, 2017 8:46 pm

Thanks for the reply! I will try switching to 2Mb.
Also, I could organize the radio PA and crazyflie2.0 from a freind of mine, so will be able to tell if the problem is crazfylie,radio or laptop related very soon.
Will keep you updated (or contact your support soonish).


Return to “Support”

Who is online

Users browsing this forum: No registered users and 1 guest