blocking of the crazyflie-led M2 blue

Posts: 6
Joined: Tue Jul 14, 2020 9:51 pm

Re: blocking of the crazyflie-led M2 blue

Post by dastonge »

Hi Kimberly,

Holding the power button while connecting the battery doesn't work neither. The bootloader and recovery bootloader are not reachable. Only M2 is blinking for both manipulation and `make cload` and cfclient flash can't connect.

However using dfu-util with the file you provided worked. We can now flash the firmware the usual way: entering bootloader mode.

Can you explain why flashing it following your instructions :
"If the Crazyflie 2.0 firmware was compiled with CLOAD=0 the binary should be flashed in the beginning of the flash (address 0x08000000). WARNING, this will overwrite the radio-bootloader if it is there. You can however flash the bootloader back this same way with DFU.
sudo dfu-util -d 0483:df11 -a 0 -s 0x08000000 -D cflie.bin"
didn't worked?

NOTE that we tried that as a last resort because our CFs were already unable to reach bootload mode.

Thank you
Posts: 616
Joined: Fri Jul 06, 2018 11:13 am

Re: blocking of the crazyflie-led M2 blue

Post by kimberly »

Ah oke, so then the bootloader was broken indeed. Happy that the dfu-util instruction worked, so for now try to only use 'make cload' with a crazyradio PA to prevent the bootloader from breaking again.

It is a very good question but apparently this was a developer feature to the crazyflie. Its a way to have more space for the firmware bin file of the crazyflie, but the is actually something that I removed in the latest version of the documentation: ... pment/dfu/ since it probably more will be confused by this. I now only mention it as a recovery mode for the bootloader and it is not in building-and-flashing anymore to make sure that people know that this is a high level developer features.

Let us know if you have any more questions or problems with the crazyflie.
Post Reply