I smell burnt IC :(

Firmware/software/electronics/mechanics
Post Reply
H0stname
Member
Posts: 43
Joined: Fri Feb 17, 2017 5:44 am

I smell burnt IC :(

Post by H0stname » Fri Apr 13, 2018 1:23 am

I was building a big quad, and kept burning through batteries in calibration so I hooked it up to my bench PSU since it's tied to a box anyway. It has a current limit of 5.2 A, but I could increase the voltage. in an effort to get more power to the drone, I turned the voltage up to 16.8 V (equivalent of 4S, hot off the charger), it worked at first, then the drone reset and I could smell a faint smell from electronics class of burnt IC! Oh no!!! I unplugged everything.

I am using these ESCs with BEC, 16.8 V is the top of the rated limit, but things have safety factors right? :lol:
https://hobbyking.com/en_us/turnigy-plu ... tore=en_us

It puts out 5 V to the big quad deck. I am thinking I somehow over volted my CF2. I have not yet checked the outputs, but the drone appears to start normally (correct sequence of light blinks, though my m1 LED fell off and I resoldered -- not reliable), but will no longer get picked up by the crazyradio. I bought two more CF2 for testing lol.

Tobias said in another post where I mentioned this:
If you put 17V on the 5V input there is a change something broke, most likely the power management controller on the CF2 or the Schottky diode on the BQ-deck.

Will I damage anything if I connect this BQ deck to a new CF2? do you think I could fix the broken parts in this drone? I should probably try reflashing new firmware in case something got corrupted, but I'll have to look up how to do that without the crazyradio. It seems I need a Jtag or SWD cable as per this:
https://wiki.bitcraze.io/doc:crazyflie:dev:starting
my bus pirate should do right? Or am I wasting my time flashing firmware?



tobias
Bitcraze
Posts: 1880
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: I smell burnt IC :(

Post by tobias » Fri Apr 13, 2018 8:43 am

I think a good idea is to check the BQ-deck since that is simplest. Hook it up to 5V, any of the 5V marked inputs, and measure the VCOM out voltage.

On the CF2 try to use your nose to find the smoked part. Often you can see a deformation to the package if it smoked as well.

Does the on/off button work as expected. Have you tried power it from USB or battery and connect to it?

Post Reply