[cfclient] PySDL version missmatch on macOS

Post here to get support
Post Reply
alex
Expert
Posts: 136
Joined: Mon Feb 18, 2013 11:36 am
Location: Germany

[cfclient] PySDL version missmatch on macOS

Post by alex » Sun Aug 02, 2020 1:43 pm

Hi,

I'm trying to run cfclient on macOS. I followed the instructions for installing on MacOSX. During installation of cfclient it says
ERROR: cfclient 2020.2 has requirement pysdl2==0.9.6, but you'll have pysdl2 0.9.7 which is incompatible.
When starting cfclient using

Code: Select all

python3 -m cfclient.gui
it says
MacBook:~ alex$ python3 -m cfclient.gui
Traceback (most recent call last):
File "/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/runpy.py", line 185, in _run_module_as_main
mod_name, mod_spec, code = _get_module_details(mod_name, _Error)
File "/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/runpy.py", line 111, in _get_module_details
__import__(pkg_name)
File "/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/cfclient/__init__.py", line 46, in <module>
VERSION = pkg_resources.require("cfclient")[0].version
File "/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/pkg_resources/__init__.py", line 901, in require
needed = self.resolve(parse_requirements(requirements))
File "/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/pkg_resources/__init__.py", line 792, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (PySDL2 0.9.7 (/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages), Requirement.parse('pysdl2==0.9.6'), {'cfclient'})
Seems like cfclient is expecting PySDL 0.9.6 instead of installed version 0.9.7.

How can I fix this?

Thanks in advance.

alex



Post Reply