[Solved]: Cfclient cant find the radio!

Post here to get support
Post Reply
khoodeh
Beginner
Posts: 2
Joined: Mon Jul 15, 2013 10:11 am
Location: Gavle, Sweden

[Solved]: Cfclient cant find the radio!

Post by khoodeh »

Hi, i got my CF for 2 days ago, and yesterday i put the kit together and was very keen to get it up in the air..

..but, once i started with the pre-assembly tests/checks, i got some issues when trying to connect to the copter!
i have installed the client software both on linux and windows with propper drivers/dependencies, and both dmesg/lsusb and windows device manager shows me the radio as a correctly working device, but there is no radio to be found in the the dialog i get when pressing connect button!

The only thing i can see is "debug://0/0 - Debugdriver for UI testing"

I'm also getting this output in the batch window (both on linux and windows) when i try to connect:

INFO:cflib.crtp.radiodriver:v0.52 dongle with serial N/A found
INFO:cflib.crtp.radiodriver:v0.52 dongle with serial N/A found



Here is the output from dmesg when insering the dongle:

[ 1102.520276] usb 6-1: >new full-speed USB device number 3 using uhci_hcd
[ 1102.685584] usb 6-1: >New USB device found, idVendor=1915, idProduct=7777
[ 1102.685597] usb 6-1: >New USB device strings: Mfr=1, Product=2, SerialNumber=29
[ 1102.685604] usb 6-1: >Product: Crazyradio USB Dongle
[ 1102.685610] usb 6-1: >Manufacturer: Bitcraze
[ 1102.685616] usb 6-1: >SerialNumber: ED91075A9A



Any clues anyone or is it something wrong with me radio HW?
Last edited by khoodeh on Mon Jul 15, 2013 11:56 am, edited 1 time in total.
foosel
Expert
Posts: 175
Joined: Sat Feb 02, 2013 9:59 pm
Location: Obertshausen, Germany
Contact:

Re: Cfclient cant find the radio!

Post by foosel »

Are you able to connect to the CF in bootloader mode?
Image
Also: AR.Drone 2.0 (RC-enabled thanks to self-soldered MiruMod) and Hubsan X4 H107
marcus
Bitcraze
Posts: 601
Joined: Mon Jan 28, 2013 7:02 pm
Location: Sweden
Contact:

Re: Cfclient cant find the radio!

Post by marcus »

Hi,

When you open the Connect dialog can you see the red LED on the Crazyradio blinking? It should take about 2 seconds to scan and during that time the red LED should blink and there should be no interfaces found. If you don't see the red LED blinking at all and the debug://.... interface shows up directly then there's an issue with opening the Crazyradio.

Like foosel suggested could you try the bootloader? It will give you an error message if you cannot open the Crazyradio dongle for communication. When you power on the Crazyflie can you see the green LED blinking rapidly a couple of times? Or is the red LED blinking over and over again?

/Marcus
foosel
Expert
Posts: 175
Joined: Sat Feb 02, 2013 9:59 pm
Location: Obertshausen, Germany
Contact:

Re: Cfclient cant find the radio!

Post by foosel »

Oh, and: You'll have to switch the CF on in order to be able to see the radio:// URL in the connect menu, you won't see that with just the Radio dongle connected, but no copter in range/powered on
Image
Also: AR.Drone 2.0 (RC-enabled thanks to self-soldered MiruMod) and Hubsan X4 H107
khoodeh
Beginner
Posts: 2
Joined: Mon Jul 15, 2013 10:11 am
Location: Gavle, Sweden

[Solved]: Cfclient cant find the radio!

Post by khoodeh »

HAHA i feel like a such a dumb ass.. :D

it was ofcourse coz i had the flie turned off.. i turned it on and did a rescan and voila, the radio://0/10/250K was there :)

everything seems to be working fine now and i just did a upgrade of the fw. Thanks everybody for the replies.

Chers
Post Reply