Programing failed

Post here to get support
Post Reply
tonyn21
Beginner
Posts: 2
Joined: Fri Mar 06, 2020 4:21 pm

Programing failed

Post by tonyn21 » Fri Mar 06, 2020 4:24 pm

Hello,

Just got cf2.1 brand new but when updating firmware to 2020.02, I get Status: Programing falied. This occurs during "writing buffer to stm32"

Edit: updating firmware through cfclient on ubuntu 18.04



tobias
Bitcraze
Posts: 1995
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: Programing failed

Post by tobias » Mon Mar 09, 2020 4:03 pm

Very strange, never seen this really. Could you take a screen shot? Does it happen at the same moment every time?

tonyn21
Beginner
Posts: 2
Joined: Fri Mar 06, 2020 4:21 pm

Re: Programing failed

Post by tonyn21 » Wed Mar 11, 2020 6:43 pm

I am trying to flash the firmware again but am now having trouble getting into bootloader mode. But to answer your question, yes it occurs at the exact same moment every time, even if I switch to a different cf

I tried flashing firmware to my old cf2.0 and it works fine.

tobias
Bitcraze
Posts: 1995
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: Programing failed

Post by tobias » Thu Mar 12, 2020 10:09 am

You might have to "cold" boot to the bootloader. Thus start from a powerless state, hold the button and then connect the battery.

What version of the cflib are you using? There was this issue but it did not happen all the time. The fix should be in the latest 0.1.9 cf-lib release.

If that doesn't fix it you could try to do a dfu update of the STM32 to rule out any flash-memory problems.

Post Reply