Crazyflie 10DOF 1.0 no motors

Post here to get support
Post Reply
mbravo
Beginner
Posts: 4
Joined: Fri Sep 26, 2014 3:23 pm

Crazyflie 10DOF 1.0 no motors

Post by mbravo »

Hi,

I have dug out my old 10DOF crazyflie 1.0 and tried to revive it. Successfully reflashed crazyradio dongle w/ 0.53 so it became visible on my Mac running Mojave. cfclient starts, finds the radio:

INFO:cflib.crtp.radiodriver:v0.53 dongle with serial N/A found

I was also able to use coldboot through the client (reset button seems not to work though, not sure if for soft or hardware reasons, it feels super soft and there's no "click" in it anymore) and flash 2017.06 firmware

copter initialises, shows up on scan, can be connected to

INFO:cflib.crazyflie:Callback->Connection initialized[radio://0/10/2M]
INFO:cflib.crazyflie:We are connected[radio://0/10/2M], request connection setup
INFO:cflib.crazyflie:Callback->Connected to [radio://0/10/2M]

and the console tab shows:

K].
IMU: HMC5883 I2C connection [OK].
IMU: MS5611 I2C connection [OK].
ESTIMATOR: Using estimator 1
MPU6050: Self test [OK].
HMC5883L: Self test [OK].
MS5611: Self test [OK].
SYS: Free heap: 1288 bytes

However, at no point motors are initialiased - no twitch from propellers.I didn't do any soldering on it for, well, years, and it flew last time I saw it. I have tried disconnecting the battery entirely (I suspect it might be dead anyway, will replace), but motors are not initialising on usb power either. Propeller test button in Console tab is greyed out. FWIW, I can't see any physical shorts between M1/M2 motor connection pad, just in case.

Any practical suggestions on how to debug what has died (and whether I can fix it) would be very much appreciated.
tobias
Bitcraze
Posts: 2059
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: Crazyflie 10DOF 1.0 no motors

Post by tobias »

The motors are connected directly to the battery to minimize resistance so a battery is needed for the motors to run.
mbravo
Beginner
Posts: 4
Joined: Fri Sep 26, 2014 3:23 pm

Re: Crazyflie 10DOF 1.0 no motors

Post by mbravo »

tobias wrote: Mon Feb 03, 2020 12:47 pm The motors are connected directly to the battery to minimize resistance so a battery is needed for the motors to run.
So dead battery equals no motors...

While we are at it, could I ask for some specs (or a link to some ) for crazyflie 1.0 compatible battery? Maybe an aliexpress/seeedstufio link? :)

Many thanks in advance!
tobias
Bitcraze
Posts: 2059
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: Crazyflie 10DOF 1.0 no motors

Post by tobias »

Unfortunately I don't have any direct suggestions but in this wiki page you can find all the spec about the battery and connector. From there you should be able to find something similar. Possible you would have to change connector on the CF1 to make it work with today's common batteries.
Post Reply