Page 1 of 1

Problem with flash 'NRF firmware'

Posted: Mon Feb 11, 2019 6:56 am
by song
Hi,
I have a problem with flash 'NRF firmware'.
I tried to flash f/w using st-link, Makefile(make flash), eclipse but it doesn't work!

First, I tried to compile with bluetooth support.

Code: Select all

./tools/build/download_deps
after this, i got a message below.

Code: Select all

In file included from src/ble/ble.c:21:0:
nrf51_sdk/nrf51822/Include/app_common/app_error.h:27:23: fatal error: nrf_error.h: No such file or directory
 #include "nrf_error.h"
                       ^
compilation terminated.
make: *** [src/ble/ble.o] Error 1
To solve this problem, I searched the forum and found other posts but nothing's different.

Second
, using the cfloader script.
https://wiki.bitcraze.io/doc:crazyflie: ... e_projects
Refer to this web-page, I tried to command 'make cload' but it doesn't work, either.
Especially, I don't understand the exact meaning of 'Restart' as pictured below.

Code: Select all

crazyflie-clients-python$ bin/cfloader flash cf2_nrf.bin nrf51-fw
Restart the Crazyflie you want to bootload in the next  10 seconds ...  
if I command 'make cload', it's required to 'Restart' as mentioned. but I don't know how to restart.
just power off/on crazyflie? or using on/off button?
I tried to use many ways but anything can help me.

Could you please tell me the details to flash both stm32 and NRF51822?
Thank you!

Re: Problem with flash 'NRF firmware'

Posted: Mon Feb 11, 2019 8:47 am
by song
After my previous posting, I found something wrong with 'Makefile'.
so i edited it like (s110_xx_7.0.0 --> s110_xx_7.3.0) and then It looks like work perfectly.
  • 'make' -> 'make factory_reset' in cf2-nrf-firmware
  • 'make' -> 'make flash' in cf2-stm32-bootloader
  • 'make'->'make flash' in cf-firmware
Everything seems to be good before i try to debug in eclipse.
In eclipse i click the 'debug' button looks like bug, and my cf2 is dead!
I mean all the led turn off. and i try to measure Voltage/Current on the board.
the result is really bad, 0.23[V] and 0.3[A]

what can i do next? i really confused with this problem. Is it broked down?
I really hope you can help me.
Thank you!

Re: Problem with flash 'NRF firmware'

Posted: Thu Feb 14, 2019 9:54 am
by arnaud
Hi,
The change you made in the Makefile is good, we had to change the stack version recently because of the link of version 7.0.0 has been removed by Nordic semi.

- Do you get your Crazyflie to boot, with the Blue LED going ON when you press the button?
- How do you power the board, USB or battery voltage?

The expected behavior after running "make factory reset" on the nRF is that the M2 blue LED will light up and the power button will work.

Then flashing the STM 32 bootloader and firmware should make the M3 Blue LED light up.

Re: Problem with flash 'NRF firmware'

Posted: Fri Feb 15, 2019 2:51 am
by song
Thanks for your reply!

- Blue LED turns on(not blinking) when i press the button.
- The voltage i mean was 'battery voltage'

It seems that i success to flash bootloader, but it's not.
Blue LED lights up after 'make factory reset' So i tried to flash stm32-bootloader. But i couldn't because st-link connect is failed suddenly.
I totally can't understand this situation.