takeoff issue with the new flow deck 2.0 + HL controller

Post here to get support
Post Reply
wydmynd
Beginner
Posts: 8
Joined: Thu Dec 06, 2018 9:25 am

takeoff issue with the new flow deck 2.0 + HL controller

Post by wydmynd » Tue Feb 05, 2019 9:37 am

Hello
I had a CF with the new flow deck 2.0 and it will not take off properly. mostly going sideways and just ... crazy behaviour.
I am using high level controller (mellinger). CF2.0 with flow deck 1.0 and same code takes off properly.
I also found that putting the CF on a stand about 80mm from the ground will allow the CF to takeoff properly.
it may be that the new Z sensor behaves differently for small distances ("blind spot") so it may require adjustments to the controller.
I'm using crazyflie_ros but I assume that it is not a ROS related issue.

Is there a suggestion what parameters I can tweak to compensate for this behaviour?

much thanks

wydmynd
Beginner
Posts: 8
Joined: Thu Dec 06, 2018 9:25 am

Re: takeoff issue with the new flow deck 2.0 + HL controller

Post by wydmynd » Sun Feb 10, 2019 10:00 am

currently have a "stand" that is a workaround for the problem. even 50mm from the ground allows for stable takeoff.
52441267-e3ad9180-2b28-11e9-84c1-ec320f558770.png

arnaud
Bitcraze
Posts: 1862
Joined: Tue Feb 06, 2007 12:36 pm

Re: takeoff issue with the new flow deck 2.0 + HL controller

Post by arnaud » Mon Feb 11, 2019 4:10 pm

If you are using the position controller for take-off, this is something that I have seed before. It is surprising that you are seeing more problem with flowV2 though, might give more clue about what is happening.

See this post for my current assumption about what is happening: viewtopic.php?f=11&t=2652&p=16038#p16038

If you take-off with velocity control and then switch ON position control, you should get better performance. Ideally I would like to find what is happening exactly to fix it. Maybe disabling or reducing the trust in flow data when bellow some height could help.

Post Reply