Page 1 of 2

Multi-Ranger left sensor [FAIL]

Posted: Sat Jan 05, 2019 11:21 pm
by placebo

I got the CF STEM Ranging bundle over the holidays and have been trying to get it working. I successfully completed the getting-started-with-the-crazyflie-2-0 tutorial but I got stuck on the getting-started-with-stem-ranging-bundle tutorial; when I run the script the CF connects (i.e. the GREEN LED for both the CF and CrazyRadio are ON.) but it just sits there motionless.

I began investigating and came across a number of strange issues. I've been able to solve most of the issues via existing posts on these forums so I thank you all for that. There are still a few problems that I've not been able to solve though. One in particular is with the Multi-Ranger (MR) deck. When I power on the CF with (or without) the MR deck connected, the self-test passes as expected. However, after the self-test, with the MR deck connected, both BLUE LED's are ON but the RED LED flashes 5 or 6 times for about 1 second and then OFF for 1 second. Rinse and repeat. I can still connect to the Crazyflie Client. Here is the output from the main menu, Help -> About -> Debug:

Code: Select all

Cfclient version: 2018.12
System: linux
Python: 3.6.8
Qt: 5.11.2
PyQt: 5.11.3

Interface status
radio: Crazyradio version 0.53
serial: None
udp: None
UsbCdc: No information available

Input readers
linuxjsdev (0 devices connected)

Input devices

Connected: radio://0/80/2M
Firmware: a203d748e139 (MODIFIED)
Sensors found
BMP388: 0
HMC5883L: 1
MS5611: 1
Sensors tests
MPU6500: 1
HMC5883L: 1
MS5611: 1
The fact that BMP388 equals 0 and the other sensors all equal 1 seems fishy. However, this is the case regardless of which decks, if any, are mounted. From the console tab:

Code: Select all

SYS: ----------------------------
SYS: Crazyflie 2.0 is up and running!
SYS: Build 0:a203d748e139 (2018.12) MODIFIED
SYS: I am 0x2035355237485008002C0041 and I have 1024KB of flash!
CFGBLK: v1, verification [OK]
DECK_DRIVERS: Found 16 drivers
DECK_INFO: Found 2 deck memories.
DECK_CORE: 2 deck enumerated
ZR2: Z-down sensor [OK]
PMW: Motion chip id: 0x49:0xB6
MPU9250 I2C connection [OK].
AK8963 I2C connection [OK].
LPS25H I2C connection [OK].
ESTIMATOR: Using estimator 2
CONTROLLER: Using controller 1
EEPROM: I2C connection [OK].
AK8963: Self test [OK].
DECK_CORE: Deck 0 test [OK].
MR: Init front sensor [OK]
MR: Init back sensor [OK]
MR: Init up sensor [OK]
MR: Init left sensor [FAIL]
MR: Init right sensor [OK]
DECK_CORE: Deck 1 test [FAIL].
The only obvious issue here is the failing left sensor. Does this mean I have a bad MR deck or could it be something else?


Re: Multi-Ranger left sensor [FAIL]

Posted: Mon Jan 07, 2019 2:46 pm
by tobias
Hi and welcome to the forum!

As can be seen in the log the left ranging sensor seam to fail. Most likely a solder problem. Fastest way to fix would be to heat up the solder that solders the small adapter board. Do it one by one and around 3 sec on each. If that doesn't work send us an email, support(at) and we will arrange a replacement.

Re: Multi-Ranger left sensor [FAIL]

Posted: Tue Jan 08, 2019 12:15 am
by placebo
I will do that. Just to be clear, the left sensor is on the port side and the right sensor is on the starboard side. Yes?

Re: Multi-Ranger left sensor [FAIL]

Posted: Tue Jan 08, 2019 11:58 am
by tobias
Yes exactly. It's the one with the text beside it.

[SOLVED] Multi-Ranger left sensor [FAIL]

Posted: Wed Jan 09, 2019 3:28 am
by placebo
I'm actually kind of surprised, but reflowing the 5 solder welds on the failing sensor worked. :D :D :D Well, at least I can now run the STEM ranging demo. Now I just need to figure out why that BMP388 is returning a 0 status code and if that is even a problem. The BMP388 isn't mentioned anywhere in the documentation or the forums. I looked it up and it's a digital pressure sensor but for what?

Re: Multi-Ranger left sensor [FAIL]

Posted: Wed Jan 09, 2019 1:10 pm
by tobias
Great! A solder might have cracked during shipping or the manufacturer did not do their job :oops: . Just let us know if you run into problems again.

As for the BMP388 it is a bit confusing and the "about->debug" output is not fully accurate anymore. The BMP388 is actually not on the CF2.0 but on the CF2.1. The CF2.0 has the LPS25H barometer. You can disregard this information and I will create a bug report on github to fix this information.

Re: Multi-Ranger left sensor [FAIL]

Posted: Thu Jan 10, 2019 2:05 am
by placebo
There's a CF2.1? Is it beta?

Re: Multi-Ranger left sensor [FAIL]

Posted: Thu Jan 10, 2019 10:28 am
by tobias
CF2.1 is to be released during Q1 2019. You can read a bit about it in this blog post.

Re: Multi-Ranger left sensor [FAIL]

Posted: Wed Jan 30, 2019 10:28 am
by wydmynd
thanks for this post! I got 5 multi ranging decks and now testing a new one and it says right sensor failed!
so will try to reflow.

also, I had one multi ranger fail completely, but that was due toa crash, replacing the 0.1" headers to new ones fixed the issue.

Re: Multi-Ranger left sensor [FAIL]

Posted: Thu Feb 28, 2019 7:02 am
by dlitz
I'm having a similar issue. I resoldered the connection, which gives me an [OK] on startup, but the range value of the left sensor seems to always be 65535 (or something close to that; I haven't looked at the numeric value, just the graph). The other sensors still appear to work. I did crash it a few times when attempting to use assisted flight, but I'm not sure whether it was working before, or whether the instability was the result of a bad sensor.

I've ordered another multi-ranger board, but I wonder is it possible to disable just that one sensor, so that its output is not used for estimating position?