flowdeck2 problem

Post here to get support
Post Reply
Posts: 7
Joined: Fri Jul 06, 2018 11:13 am

flowdeck2 problem

Post by knmcguire » Wed Oct 24, 2018 9:40 am

Hi all,

I just purchased the new flowdeckv2, however my crazyflie2 has trouble reading it out. It recognize the deck but I get the following readout in the console, along with the 3 times fast blink of M1:
SYS: ----------------------------
SYS: Crazyflie 2.0 is up and running!
SYS: Build 187:47ee696b2d3c (2018.01.1-187) CLEAN
SYS: I am 0x30343631303747130031003A and I have 1024KB of flash!
CFGBLK: v1, verification [OK]
DECK_DRIVERS: Found 16 drivers
DECK_INFO: Found 1 deck memory.
DECK_CORE: 1 deck enumerated
ZR2: Z-down sensor [FAIL]
PMW: Motion chip id: 0x49:0xB6
MPU9250 I2C connection [OK].
AK8963 I2C connection [OK].
LPS25H I2C connection [OK].
ESTIMATOR: Using estimator 2
CONTROLLER: Using controller 1
EEPROM: I2C connection [FAIL].
AK8963: Self test [OK].
DECK_CORE: Deck 0 test [FAIL].

It seems that the vl53l1x fails to init for some reason. Anybody has the same problem?

With the latest master of crazyflie-firmware github repository, I tried it on two different CF2's, with two different flowdeck v2's. I also tried the flowdeck v1, however that still works with the current master.

Posts: 7
Joined: Fri Jul 06, 2018 11:13 am

Re: flowdeck2 problem

Post by knmcguire » Wed Oct 24, 2018 2:59 pm

I was able to sort of trace the problem down to the I2C communication. Unfortunately my gdb debugging on the stm doesn't work so I can't really efficiently debug it any further.

However, the following line is quite interesting:
EEPROM: I2C connection [FAIL].
If I remove the flowdeckv2, or replace it with a flowdeckv1, it turns into:
EEPROM: I2C connection [OK].

Maybe that could hint that the flowdeckv2 is interfering with the I2C communication of the eeprom memory module in some way?

Posts: 1
Joined: Wed Oct 24, 2018 3:21 pm

Re: flowdeck2 problem

Post by Shushuai » Wed Oct 24, 2018 3:29 pm

I also have the same problem. Even if I used the firmware crazyflie-2018.10.zip which should support Flow V2 deck. The firmware link is https://github.com/bitcraze/crazyflie-r ... ag/2018.10

Probably it is the i2c communication conflict between VL53L1x and onboard EEPROM.

Posts: 1758
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: flowdeck2 problem

Post by tobias » Tue Oct 30, 2018 2:19 pm

Hi all!

We found a production problem with the first Flow v2 decks. The test rig have damaged the connector. This is possible to fix with the tip off a needle and if that doesn't work send us a support mail and we will arrange with replacements (that will take time though :oops: )

Fixing steps.
  1. Get a small needle (around 0.5mm in diameter)
  2. Start with one pin and push the needle though the contact. If there is no or minimal friction it needs to be fixed.
  3. Use the tip of the needle to get behind the inner golden "tongue" and gently bend it out. There are two tongues, front and back, that can be adjusted.
  4. Test the contact again. If it was bent out to much test from the bottom to not risking over-bending the tongue the wrong way. If it was bent to little, redo it.
  5. Repeat this for all contacts. Takes around 5min when you got the hang of it.

Post Reply