[SOLVED] Upgrade via bluetooth failed and now is dead

Post here to get support
Post Reply
alexpacket
Beginner
Posts: 4
Joined: Wed Oct 14, 2015 6:32 pm

[SOLVED] Upgrade via bluetooth failed and now is dead

Post by alexpacket » Wed Oct 14, 2015 6:43 pm

Do you know how can I restore my crazyflie 2.0 from a failed upgrade via bluetooth (IOS app). Actually only the power led is on, all other leds are off.
Unplug and plug back the battery does not helps. The upgrade progress was good until it send a timeout error message.

Helps will be appreciated.



tobias
Bitcraze
Posts: 1914
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: Upgrade via bluetooth failed and now is dead

Post by tobias » Wed Oct 14, 2015 6:57 pm

You should be able to try again. Start in bootloader mode (hold down power button until blue led starts to blink when powering on). Tell me how it goes.

alexpacket
Beginner
Posts: 4
Joined: Wed Oct 14, 2015 6:32 pm

Re: Upgrade via bluetooth failed and now is dead

Post by alexpacket » Wed Oct 14, 2015 8:50 pm

Tobias,
thank you for the advice. I was able to get the blue led (power led) flashing by disconnecting the battery holding the on/off button. it is still flashing but when I try to run the upgrade via ios app it sends the error message: "bootloader connection: timeout".

The only way to shut the crazyflie off is by disconnecting the battery.

I will appreciate your help.

marcus
Bitcraze
Posts: 599
Joined: Mon Jan 28, 2013 7:02 pm
Location: Sweden
Contact:

Re: Upgrade via bluetooth failed and now is dead

Post by marcus » Thu Oct 15, 2015 7:17 am

Hi,

Is there only one blue LED blinking, or two? If you enter bootloader mode then both of the blue LEDs should blink.

Here's a Vine showing what it should look like. If you hold the button for too long only one LED will blink and the STM32 will go into DFU mode, which is not what you want.

alexpacket
Beginner
Posts: 4
Joined: Wed Oct 14, 2015 6:32 pm

Re: Upgrade via bluetooth failed and now is dead

Post by alexpacket » Thu Oct 15, 2015 1:53 pm

Marcus,
thank you for your reply.
1. only the power blue led is flashing all other leds are off.
2. If I connect the crazyflie to the power the blue led (charge indicator) is still off, I am mentioning this because it should turn on when you connect the power to charge the battery.

3. only wait to shutdown the drone is by unplugging the battery. in order to make the only led flash I have to unplug and plug back the battery and hold the on/off button.

Have you seeing before this issue? any idea on how to recover?

marcus
Bitcraze
Posts: 599
Joined: Mon Jan 28, 2013 7:02 pm
Location: Sweden
Contact:

Re: Upgrade via bluetooth failed and now is dead

Post by marcus » Thu Oct 15, 2015 2:05 pm

Ok, we will look into it and see if we can reproduce it. The behavior your are describing matches what happens when you hold down the button for more than 6 seconds. But it doesn't match what happens if you hold it down less. If you hold it for more than 6 seconds the blue LED will start to flash faster and after you release it only one blue LED will flash and you will not be able to turn off the Crazyflie with the power button. To enter bootloader mode you should only hold down the button 4-6 seconds.

The blue LED should not go on when you connect it via USB, you still need to press the power button to start it.

alexpacket
Beginner
Posts: 4
Joined: Wed Oct 14, 2015 6:32 pm

Re: Upgrade via bluetooth failed and now is dead

Post by alexpacket » Thu Oct 15, 2015 3:02 pm

Marcus,
Just as an update. I let the crazyflie all night for letting the battery charge is finished, Today I connected the drone to the usb to put some charge and after a few minutes I disconnected the USB cable I pushed the on/off switch and it went off, then I pushed again the on/off switch for about 4 sec and both of the blue leds started flashing then I started the upgrade process again via ios app and this time everything worked good.


Thank you...

marcus
Bitcraze
Posts: 599
Joined: Mon Jan 28, 2013 7:02 pm
Location: Sweden
Contact:

Re: Upgrade via bluetooth failed and now is dead

Post by marcus » Thu Oct 15, 2015 3:29 pm

Glad to hear that it's working. Thanks for the update!

Post Reply