MPU6050: Self test acc Y [FAIL] - motor problem?

Post here to get support
leland
Beginner
Posts: 9
Joined: Thu May 23, 2013 7:14 pm

Re: MPU6050: Self test acc Y [FAIL] - motor problem?

Post by leland » Tue May 28, 2013 7:31 pm

Hello, after a day of really nice flying (and finally seeming to get the hang of controlling the CF 10DOF using the thrust/pitch/roll controls of the PS3), I now have a problem per this thread, with the red LED rapid flashing and this console message:

ng!
SYS: Build 31:ba1d111112ad (2013.4) CLEAN
SYS: I am 0x8722375453568549671FF54 and I have 128KB of flash!
IMU: MPU6050 I2C connection [OK].
IMU: HMC5883 I2C connection [OK].
IMU: MS5611 I2C connection [OK].
MPU6050: Self test acc Y [FAIL]. low: 0.300000, high: 0.949999, measured: 0.0

Have tried Tobias' suggestions to no avail, re-flashed the firmware using bootloader, but no progress.

No dramatic crashes of note, and examined both sides of the CF under a magnifying glass, and nothing to the eye jumps out.

Happy to try any further suggestions.

Thanks very much in advance, Leland



TheFrog4u
Expert
Posts: 113
Joined: Fri Feb 08, 2013 6:59 pm
Location: Bremen, Germany

Re: MPU6050: Self test acc Y [FAIL] - motor problem?

Post by TheFrog4u » Tue May 28, 2013 7:44 pm

@leland: I am sry for you, but its likely that you seem to be also a victim of a broken MPU6050 chip.. Seem to get a serious problem for the cf :(
tobias wrote:Then please open a support case at Seeedstudio.

leland
Beginner
Posts: 9
Joined: Thu May 23, 2013 7:14 pm

Re: MPU6050: Self test acc Y [FAIL] - motor problem?

Post by leland » Tue May 28, 2013 7:55 pm

Hello, yes, a bit of a let down, esp. after the wonderful experience of actually flying the CF!

Just opened a 'Quality Issue' with Seeedstudio Customer Service.

Cheers, Leland

tobias
Bitcraze
Posts: 1996
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: MPU6050: Self test acc Y [FAIL] - motor problem?

Post by tobias » Tue May 28, 2013 8:16 pm

Yes, this looks like a broken MPU6050 and just as TheFrog4u wrote contact Seeedstudio customer support.

It is starting to be a bit worrying. We have never managed to break a MPU6050 and that would include a lot of crashes and many nasty ones. We will have to start an investigation to try and find the problem.

leland
Beginner
Posts: 9
Joined: Thu May 23, 2013 7:14 pm

Re: MPU6050: Self test acc Y [FAIL] - motor problem?

Post by leland » Tue May 28, 2013 8:32 pm

Hello, thanks for the note.

Certainly interested to hear what you (the developers) and the tech support folks at Seeedstudio turn up.

Cheers, Leland

foosel
Expert
Posts: 175
Joined: Sat Feb 02, 2013 9:59 pm
Location: Obertshausen, Germany
Contact:

Re: MPU6050: Self test acc Y [FAIL] - motor problem?

Post by foosel » Tue May 28, 2013 10:02 pm

Might be interesting to try narrowing this down on charges... E.g. does it only happen with the first batch of pre-order kits, only on 10-DOF versions etc...

edit
CF 10DOF
1st batch
Image
Also: AR.Drone 2.0 (RC-enabled thanks to self-soldered MiruMod) and Hubsan X4 H107

leland
Beginner
Posts: 9
Joined: Thu May 23, 2013 7:14 pm

Re: MPU6050: Self test acc Y [FAIL] - motor problem?

Post by leland » Tue May 28, 2013 11:16 pm

Hello, good thought:

CF 10DOF
2nd batch

Cheers, Leland

leland
Beginner
Posts: 9
Joined: Thu May 23, 2013 7:14 pm

Re: MPU6050: Self test acc Y [FAIL] - motor problem?

Post by leland » Wed May 29, 2013 10:37 am

Hello, this just in from the Seeedstudio Customer Support folks:

'Is that ok for you to send it back to us? We offer you free repair and will send it back to you after we fix it.'

Will certainly do so and hope for the best (and will follow the Forum with interest in the interim).

Cheers, Leland

stefan
Beginner
Posts: 3
Joined: Thu May 30, 2013 7:30 am
Location: Munich, Germany

Re: MPU6050: Self test acc Y [FAIL] - motor problem?

Post by stefan » Thu May 30, 2013 7:44 am

The same problem here (CF 10DOF 1st batch):

SYS: Build 31:ba1d111112ad (2013.4) CLEAN
SYS: I am 0x871233375456854966BFF50 and I have 128KB of flash!
IMU: MPU6050 I2C connection [OK].
IMU: HMC5883 I2C connection [OK].
IMU: MS5611 I2C connection [OK].
MPU6050: Self test acc Y [FAIL]. low: 0.300000, high: 0.949999, measured: 0.0

Moving it slowly after turning it on doesn't solve the problem.

I guess I also have to contact Seeedstudio...

Is there any new feedback form the customer service?

Cheers,
Stefan

foosel
Expert
Posts: 175
Joined: Sat Feb 02, 2013 9:59 pm
Location: Obertshausen, Germany
Contact:

Re: MPU6050: Self test acc Y [FAIL] - motor problem?

Post by foosel » Thu May 30, 2013 9:17 am

stefan wrote:Is there any new feedback form the customer service?
They are offering to repair it for free, got the email as well.
Image
Also: AR.Drone 2.0 (RC-enabled thanks to self-soldered MiruMod) and Hubsan X4 H107

Post Reply