CF Bolt - Stabilizer gets stuck waiting for sensor calibration

Post here to get support
Post Reply
naiveHobo
Beginner
Posts: 5
Joined: Wed Feb 12, 2020 10:58 pm

CF Bolt - Stabilizer gets stuck waiting for sensor calibration

Post by naiveHobo »

I'm trying to setup a custom quadrotor using CF Bolt. On connecting the bolt to the cfclient, the stabilizer seems to get stuck while waiting for sensor calibration. I have tested 2 bolts with a fresh latest (2021.06) firmware flash. The first bolt is mounted on a 3D printed frame and connected with 4 ESCs. When I faced the issue with the first bolt, I tested the second bolt which was fresh out of the box and not connected to any ESC. The problem persists with both bolts.

Cfclient Console log for your reference:

Code: Select all

SYS: Crazyflie Bolt is up and running!
SYS: Production release 2021.06
SYS: I am 0x20373347344D500E002D003D and I have 1024KB of flash!
CFGBLK: v1, verification [OK]
DECK_CORE: 0 deck(s) found
IMU: BMI088: Using SPI interface.
IMU: BMI088 Gyro connection [OK].
IMU: BMI088 Accel connection [OK]
IMU: BMP388 I2C connection [OK]
ESTIMATOR: Using Complementary (1) estimator
CONTROLLER: Using PID (1) controller
MTR-DRV: Using brushless motor driver
SYS: About to run tests in system.c.
EEPROM: I2C connection [OK].
STORAGE: Storage check [OK].
IMU: BMI088 gyro self-test [OK]
SYS: Self test passed!
STAB: Wait for sensor calibration...
SYS: Free heap: 20560 bytes
Having gone through a similar topic on the forum (viewtopic.php?t=4420), I logged the gyro variances for both the bolts. Though I find it hard to believe that 2 bolts (ordered together about 2 weeks ago) would have the same issue as mentioned in the linked topic.

Bolt 1 (mounted on frame and ESCs attached):
cfclient3.png
Bolt 2 (just the bolt, nothing attached):
cfclient1.png
Any help would be immensely appreciated!
naiveHobo
Beginner
Posts: 5
Joined: Wed Feb 12, 2020 10:58 pm

Re: CF Bolt - Stabilizer gets stuck waiting for sensor calibration

Post by naiveHobo »

There's actually 3 bolts that I have right now, all ordered together and received about 10 days ago. All three seem to have the same issue. Am I missing some setup step here?
tobias
Bitcraze
Posts: 2248
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: CF Bolt - Stabilizer gets stuck waiting for sensor calibration

Post by tobias »

Like you say, if it would have been only one, I would have blamed the BMI088 IMU sensor, but now I'm actually thinking there are vibrations in the ground or similar. The threshold is quite tightly set. I suggest you try to increase it here to 20000 - 25000 and test.
naiveHobo
Beginner
Posts: 5
Joined: Wed Feb 12, 2020 10:58 pm

Re: CF Bolt - Stabilizer gets stuck waiting for sensor calibration

Post by naiveHobo »

Increasing the gyro variance threshold to 20000 worked! I could guarantee there are no vibrations in the ground, is there any other reason why I could be getting high gyro variance with all 3 bolts? Also, would increasing the threshold affect flight in any way?

Thank you so much for the quick response and fix by the way, really appreciate it!
tobias
Bitcraze
Posts: 2248
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: CF Bolt - Stabilizer gets stuck waiting for sensor calibration

Post by tobias »

Glad it worked! A bad power supply is the only other reason I can come up with, but as I said, the threshold is very tightly set. If holding the CF in your hand as still as one possibly can it is hard to reach values below 100k for x/y. I don't expect any change in performance but that is hart to tell without doing a thorough analysis.
Post Reply