gap_sdk v-3.8.1

Discussions about the AI-deck
Post Reply
1pi
Beginner
Posts: 11
Joined: Mon Nov 23, 2020 1:28 am

gap_sdk v-3.8.1

Post by 1pi »

Hello
I have upgraded the gap_sdk to version 3.8.1, when I try to program the face detection example I get this message
ModuleNot Found error:no module named ‘elf tools’.
I tried to install pyelftools with pip but still getting the same message. I am using Ubuntu 18.04.
Regards
Rodrigo
yaooooo
Beginner
Posts: 2
Joined: Fri Jun 05, 2020 2:18 pm

Re: gap_sdk v-3.8.1

Post by yaooooo »

Hi,

Can you please check which version of pip you are using?
It seems a problem of python package management. We strongly recommand you to use "Anaconda": https://www.anaconda.com/products/individual
After installing the Anaconda, please configure a env for python3, then install all the packages in the sdk/requirements.txt
You can run :
pip install -r requirements.txt

If you don't want to use anaconda, then please make sure you are using python3 and pip3 for installing the pacakges.
You can do an easy test:
$python or $python3
<Normally you will see your python version>
>>>> import elftools

Regards,
Yao
Post Reply