Issue when flashing AI deck and crazyflie firmware

Discussions about the AI-deck
Post Reply
atagliavini
Beginner
Posts: 2
Joined: Mon Feb 01, 2021 4:10 pm

Issue when flashing AI deck and crazyflie firmware

Post by atagliavini »

Hello!

I'm trying to run the example "uart-send-char", so i flashed the CF firmware forcing the driver of the AI-deck, then i compile the example and run "make image flash", my goal here is to print the character that the AI deck writes on the UART (i put a DEBUG_PRINT in the ai deck driver).
The problem is that if I do things in this order, while flashing the image on the AI deck, i receive these errors:

Code: Select all

Error: JTAG scan chain interrogation failed: all ones
Error: Check JTAG interface, timings, target power, etc.
Error: Trying to use configured scan chain anyway...
Error: gap8.cpu: IR capture error; saw 0x0f not 0x01
Warn : Bypassing JTAG setup events due to errors
GAP8 examine target
Init jtag
Initialising GAP8 JTAG TAP
Info : adv debug unit is configured with option BOOT MODE JTAG
Info : adv debug unit is configured with option ADBG_USE_HISPEED
Warn : CRC ERROR! Computed 0x00000000, read CRC 0xffffffff
Warn : CRC ERROR! Computed 0x00000000, read CRC 0xffffffff
I noticed that if i turn off the cf and then boot it up some seconds later i can flash the image normally, however once I do that, i am unable to connect to the crazyflie using the cfclient.
I can see the interface, but when i click on "Connect" it tries to connect forever without success.
The terminal however shows that the connection is indeed occurred

Code: Select all

INFO:cflib.crazyflie:Callback->Connection initialized[radio://0/80/2M]
INFO:cflib.crazyflie:We are connected[radio://0/80/2M], request connection setup
INFO:cflib.crazyflie:Callback->Connected to [radio://0/80/2M]
So it seems that I'm messing something up when flashing one of either components, could somebody give me some suggestions?
Thanks in advance.

GAP_SDK version: 3.8.1
OS: Ubuntu 20.04 / 18.04
Cable: olimex-arm-usb-tiny-h
kimberly
Bitcraze
Posts: 748
Joined: Fri Jul 06, 2018 11:13 am

Re: Issue when flashing AI deck and crazyflie firmware

Post by kimberly »

It seems from they terminal print out that the crazyflie is connected. Can you try to connect with your crazyflie with the cfclient with a cable?
atagliavini
Beginner
Posts: 2
Joined: Mon Feb 01, 2021 4:10 pm

Re: Issue when flashing AI deck and crazyflie firmware

Post by atagliavini »

I re flashed the CF with the original firmware and used the logging framework to get the value (instead of using the debug print) and the problem seems to be solved (I am able to see the correct value from the log files).
My guess is that I probably didn't compile the firmware correctly in the first place (shame on me :mrgreen:).
If the problem comes up again I'll try to isolate it and post updates.
kimberly
Bitcraze
Posts: 748
Joined: Fri Jul 06, 2018 11:13 am

Re: Issue when flashing AI deck and crazyflie firmware

Post by kimberly »

Ah oke good! it might have been that there was too many printfs (debug_print), that can cause the connection to be cluttered. But there is a log variable for it so its better to use that instead.
Post Reply