AI-deck can't release WiFi

Discussions about the AI-deck
Aadequate
Beginner
Posts: 9
Joined: Fri Jan 15, 2021 4:58 am

AI-deck can't release WiFi

Post by Aadequate »

Hi!
The problem is in the attachment. I am eager for your help!Thank you.
Attachments
Problem of AI-deck.pdf
(942.49 KiB) Downloaded 32 times
Problem of AI-deck.docx
(827.23 KiB) Downloaded 30 times
kimberly
Bitcraze
Posts: 748
Joined: Fri Jul 06, 2018 11:13 am

Re: AI-deck can't release WiFi

Post by kimberly »

Hi!

And thanks for the elaborate explanation of your problem

GAP8
So it seems that the first config parser is because that part of the SDK is where python v2 is used we figured. This is indeed an issue that we had ourselves. So you will need to get this package for python2

Nina
Make menu is where you can configure if you want the NINA module to be an accesspoint (you connect to it), or connect to an existing wifi point itself (it connects to an existing wifi). If you don't change anything, it will be act as an accesspoint (AP), so you can connect to it directly, so pressing exit was fine.

I'm not sure what that error implies when you tried to flash it... are you sure that you are connect to the right JTAG connector? Its on the right side of the NINA module (seen from the picture) and it is written on it.


What you can also try for both the NINA and GAP8, is to use docker to flash it. We have provided instructions to build the containers, so that it makes a small 'virtual machine' on your computer just for flashing those chips, which has worked for many so far that have problems with installing it on their native machines. Here you can find the instructions for building thegap8 docker and the nina docker
Aadequate
Beginner
Posts: 9
Joined: Fri Jan 15, 2021 4:58 am

Re: AI-deck can't release WiFi

Post by Aadequate »

Hi,
--->'I'm not sure what that error implies you tried to flash it...'
It's worth emphasizing that I want to refresh gap8 and Nina because my AI deck can't release WiFi signal.
Or,accroding to your this sentence,can I understand that the failure to release WiFi is mainly due to the problems with gap8, not Nina?
Since it can't release WiFi, so I tried to flash both(it's a try,since I don't know the principle). But Nina's mistake made me feel very uneasy(For example,I'd like to think that the ARM-USB-TINY-H is broken).I can see the English on the board, so I'm sure I have the right JTAG connector.

--->For GAP8:
Using python2 does solve the above problems. Thank you very much.
But when using the command 'make gap_tools',there is still a problem. The error is as follows:
---------------------------------------------------------------------------------------------
zjh@ubuntu:~/gap_sdk$ make gap_tools
make -C /home/zjh/gap_sdk/tools/gap_tools all
make[1]: Entering directory '/home/zjh/gap_sdk/tools/gap_tools'
#### Building in /home/zjh/gap_sdk/build
#### Installing to /home/zjh/gap_sdk/install/GAP8_V2
Package opencv was not found in the pkg-config search path.
Perhaps you should add the directory containing `opencv.pc'
to the PKG_CONFIG_PATH environment variable
No package 'opencv' found
g++ -std=c++11 -O2 -g -fPIC -MMD -MP -I/usr/include/SDL2 -D_REENTRANT -D__USE_SDL__ -D__USE_OPENCV__ -I/home/zjh/gap_sdk/install/workstation/include -I/home/zjh/gap_sdk/tools/gap_tools/include -o /home/zjh/gap_sdk/build/python/pmsis_tools_frame_streamer.o -c python/pmsis_tools_frame_streamer.cpp
python/pmsis_tools_frame_streamer.cpp:24:10: fatal error: opencv2/core/core.hpp: No such file or directory
#include <opencv2/core/core.hpp>
^~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
Makefile:42: recipe for target '/home/zjh/gap_sdk/build/python/pmsis_tools_frame_streamer.o' failed
make[1]: *** [/home/zjh/gap_sdk/build/python/pmsis_tools_frame_streamer.o] Error 1
make[1]: Leaving directory '/home/zjh/gap_sdk/tools/gap_tools'
Makefile:103: recipe for target 'gap_tools' failed
make: *** [gap_tools] Error 2
---------------------------------------------------------------------------------------------

Does that mean I need to manually compile and install opencv?

Looking forward to your reply!thank you!
kimberly
Bitcraze
Posts: 748
Joined: Fri Jul 06, 2018 11:13 am

Re: AI-deck can't release WiFi

Post by kimberly »

It depends of where you got the AIdeck, but if you don't see a wifi hotspot created by the aideck, you need to flash both of them.

You can try:

Code: Select all

RUN apt-get install -y libopencv-dev python3-opencv
Btw, the docker file can also show what needs to be installed for it to work properly. I use the docker images myself since it is just so much easier to flash both the nina and gap8 and don't have to worry about the packages that I have on my locale machine, so I highly recommend it.
Aadequate
Beginner
Posts: 9
Joined: Fri Jan 15, 2021 4:58 am

Re: AI-deck can't release WiFi

Post by Aadequate »

I took your advice to use docker.
And I have solved some problems in the process these days, but the following error I did not find a good solution on the Internet. I don't know if you have any suggestions.
It has to be said that if you directly install the SDK, it is too complicated. However, with docker, due to China's network restrictions, there are various error reporting problems. I hope you know the solution to this git problem.
-------------------------------------------------------------------------------------------------------
Step 9/21 : RUN git clone https://github.com/GreenWaves-Technologies/gap_sdk.git; cd gap_sdk && git fetch --all --tags && git checkout tags/release-v${GAP_SDK_VERSION} && git submodule update --init --recursive
---> Running in 6fede4792f51
Cloning into 'gap_sdk'...
Checking out files: 100% (17564/17564), done.
Fetching origin
error: pathspec 'tags/release-v' did not match any file(s) known to git.
The command '/bin/sh -c git clone https://github.com/GreenWaves-Technologies/gap_sdk.git; cd gap_sdk && git fetch --all --tags && git checkout tags/release-v${GAP_SDK_VERSION} && git submodule update --init --recursive' returned a non-zero code: 1
---------------------------------------------------------------------------------------------------------
kimberly
Bitcraze
Posts: 748
Joined: Fri Jul 06, 2018 11:13 am

Re: AI-deck can't release WiFi

Post by kimberly »

hi!

This does not seem that it is a internet restriction problem. Make sure that you have the right SDK version defined before starting to build the docker file. This means that you need to (in your local machine) define the SDK version like this in the terminal:

Code: Select all

export GAP_SDK_VERSION=3.8.1
Or add it to the ~/.bashrc file and restart the terminal again

Code: Select all

echo 'export GAP_SDK_VERSION=3.8.1' >> ~/.bashrc 
currently this seems to not have been done correctly due this error in your previous message:

Code: Select all

error: pathspec 'tags/release-v' did not match any file(s) known to git.
This is supposed to be 'tags/release-v3.8.1' (because of git checkout tags/release-v${GAP_SDK_VERSION}), so currently ${GAP_SDK_VERSION} is not defined in your terminal

I would say, please try again to go through the docker guide but make sure to read every step.
Aadequate
Beginner
Posts: 9
Joined: Fri Jan 15, 2021 4:58 am

Re: AI-deck can't release WiFi

Post by Aadequate »

I did follow the guidelines.But it still reports errors, as you can see in the attachment.In the past, I have successfully passed this step.I've never met this error report.(Instead, an error will be reported at the back, saying that the connection cannot be made raw.githubusercontent.com.That's what I mean by China's Internet restrictions)
As for the present problem, I did take the first two steps.And it's never been wrong, except this time.It doesn't help that I've reinstalled the virtual machine.
Attachments
I)P@YLSV{6%8F{31YYJN3T9.png
kimberly
Bitcraze
Posts: 748
Joined: Fri Jul 06, 2018 11:13 am

Re: AI-deck can't release WiFi

Post by kimberly »

that is odd indeed. Reinstalling the virtual machine should not make any difference so let's investigate a little bit.

1- Could you open the .bashrc file by:

Code: Select all

gedit ~/.bashrc 
and check if 'export GAP_SDK_VERSION=3.8.1' is at the end of the file?

2- If you see it, restart the terminal or do

Code: Select all

source ~/.bashrc
3- And double check with

Code: Select all

echo ${GAP_SDK_VERSION}
This should print the number 3.8.1

4- After that, build again but then with the --no-cache option:

Code: Select all

docker build --no-cache --tag gapsdk:${GAP_SDK_VERSION} --build-arg GAP_SDK_VERSION .
And check if you are getting the same echo at step 4/21
Aadequate
Beginner
Posts: 9
Joined: Fri Jan 15, 2021 4:58 am

Re: AI-deck can't release WiFi

Post by Aadequate »

I'm sorry to say that I still can't solve this problem.Every time I compile, it takes a long time, and there is a certain probability that it will not succeed. If I use the no caching method, the success rate will be lower.For now, at least for me, docker based solutions are cumbersome.
But the scheme without docker is very messy. I can't make sense of the logical order.I wonder if you can provide me with a detailed homework method without using docker?
By the way,it's OK to buy a new ai-deck which can work normally from your net shop.But it seems to have no supply?How can I solve the problem now?
kimberly
Bitcraze
Posts: 748
Joined: Fri Jul 06, 2018 11:13 am

Re: AI-deck can't release WiFi

Post by kimberly »

Did you follow the checklist I gave last time, and is there anything there is wrong with the outcome any of the 4 steps? The first 3 out of 4 are precompile steps and the 4th step ( 4/21 in the docker compile) occurs very quickly, so it should not take long for those to check it out. If I don't get feedback on what goes wrong in any of those, then it is difficult to help you with docker.

On the documentation there is a link to the gap sdk install instructions to install natively on your virtual machine.

We will have an update on the AIdeck before the end of this week so keep an eye on the shop. Currently there is no AIdeck in stock but there will be soon. We also had a blogpost about the aideck recently.
Post Reply