Docker issue

Discussions about the AI-deck
Post Reply
1pi
Beginner
Posts: 2
Joined: Mon Nov 23, 2020 1:28 am

Docker issue

Post by 1pi »

Hello Kimberley
I am running into a problem when creating the image for gapsdk v3.6 on docker, I get this error:
pathspec ‘tags/release-v’ did not match any file(s) known to git.
The command bin/sh -c cd gap_sdk && git fetch —all —tags && git checkout tags/release-v${GAP_SDK_VERSION} && git submodule update —init —recursive’ returned a non-zero code :1
And the process stops here. Could you let me know what am I doing wrong.
By the way I am now using the olimex compiler.
Regards
Rodrigo
kimberly
Bitcraze
Posts: 704
Joined: Fri Jul 06, 2018 11:13 am

Re: Docker issue

Post by kimberly »

hi!

Which OS are you building the docker image on? This was done on Ubunti 18.04 and 20.04

You are supposed to get pathspec ‘tags/release-v3.6', so probably the GAP_SDK_VERSION is not set properly. Try this again in the same window as you docker:

Code: Select all

export GAP_SDK_VERSION=3.6
and try to check it with

Code: Select all

echo $GAP_SDK_VERSION
You can also put the version variable permanantly in your bashrc file. See the instructions here.
raven
Member
Posts: 32
Joined: Thu Sep 24, 2020 1:57 pm
Contact:

Re: Docker issue

Post by raven »

I created a pull request to solve this problem.
https://github.com/bitcraze/AIdeck_examples/pull/34
Make positive impact.
Post Reply