Lighthouse Deck Red and Blue LED Remaining On

Topics related to the Lighthouse positioning system, configuration and use
Post Reply
jjan3640
Beginner
Posts: 3
Joined: Tue Mar 30, 2021 4:18 am

Lighthouse Deck Red and Blue LED Remaining On

Post by jjan3640 »

I am trying to get accurate positioning data using the Lighthouse deck with v1 HTC Vive base stations however it does not seem to be working. The console output describes the bitstream not matching the required bitstream.

Is there a way to solve this issue?

Here is the console output:

Code: Select all

SYS: ----------------------------
SYS: Crazyflie 2.1 is up and running!
SYS: Build 1:2c672817f171 (2021.03 +1) CLEAN
SYS: I am 0x20373357594B50070042002D and I have 1024KB of flash!
CFGBLK: v1, verification [OK]
DECK_CORE: 1 deck(s) found
DECK_CORE: Calling INIT on driver bcLighthouse4 for deck 0
IMU: BMI088: Using I2C interface.
IMU: BMI088 Gyro connection [OK].
IMU: BMI088 Accel connection [OK]
IMU: BMP388 I2C connection [OK]
ESTIMATOR: Using Kalman (2) estimator
CONTROLLER: Using PID (1) controller
MTR-DRV: Using brushed motor driver
EEPROM: I2C connection [OK].
STORAGE: Storage check [OK].
IMU: BMI088 gyro self-test [OK]
STAB: Wait for sensor calibration...
SYS: Free heap: 19248 bytes
LHFL: Lighthouse bootloader version: 2
STAB: Ready to fly.
LHFL: Bitstream CRC32: 296D0C45 [FAIL]
LHFL: The deck bitstream does not match the required bitstream.
LHFL: We require lighthouse bitstream of size 104093 and CRC32 112BC794.
LHFL: Leaving the deck in bootloader mode ...
LH: FPGA not booted. Lighthouse disabled!
whoenig
Expert
Posts: 377
Joined: Mon Oct 27, 2014 2:55 am

Re: Lighthouse Deck Red and Blue LED Remaining On

Post by whoenig »

You need to update the firmware with the LH deck installed using the latest cfclient and release 2021.03. You can find instructions for the update procedure at https://www.bitcraze.io/documentation/t ... #update-fw. If you updated your firmware using an older cfclient, your LH deck might not have been upgraded to the latest deck firmware.
borat22
Beginner
Posts: 3
Joined: Thu Sep 17, 2020 9:12 am

Re: Lighthouse Deck Red and Blue LED Remaining On

Post by borat22 »

i have the same problem with the lighthouse deck. i tried to flash it with newest cfclient and with the newest firmware. I think something is wrong with my lighthouse deck, because the blue and red led remain on and the console log says this:


SYS: ----------------------------
SYS: Crazyflie 2.0 is up and running!
SYS: Production release 2021.03
SYS: I am 0x3335303035364711003A002E and I have 1024KB of flash!
CFGBLK: v1, verification [OK]
DECK_CORE: 1 deck(s) found
DECK_CORE: Calling INIT on driver bcLighthouse4 for deck 0
MPU9250 I2C connection [OK].
AK8963 I2C connection [OK].
LPS25H I2C connection [OK].
ESTIMATOR: Using Kalman (2) estimator
CONTROLLER: Using PID (1) controller
MTR-DRV: Using brushed motor driver
EEPROM: I2C connection [OK].
STORAGE: Storage check [OK].
AK8963: Self test [OK].
STAB: Wait for sensor calibration...
SYS: Free heap: 19248 bytes
LHFL: Lighthouse bootloader version: 2
STAB: Ready to fly.
LHFL: Bitstream CRC32: B363DC3 [FAIL]
LHFL: The deck bitstream does not match the required bitstream.
LHFL: We require lighthouse bitstream of size 104093 and CRC32 112BC794.
LHFL: Leaving the deck in bootloader mode ...
LH: FPGA not booted. Lighthouse disabled!
whoenig
Expert
Posts: 377
Joined: Mon Oct 27, 2014 2:55 am

Re: Lighthouse Deck Red and Blue LED Remaining On

Post by whoenig »

Was the LH deck installed during flashing? In the progress bar at the bottom of the flash dialog, does it actually show you that it attempts to flash the LH deck when you upgrade to 2021.03?
borat22
Beginner
Posts: 3
Joined: Thu Sep 17, 2020 9:12 am

Re: Lighthouse Deck Red and Blue LED Remaining On

Post by borat22 »

Yes it was flashed multiple times with the deck on it and it said update deck briefly after a restart.

Full story:
I flashed the firmware with the app and my phone shutoff, because of this the crazyflie was stuck and the crazyflie didnt respond (only one blue light was on).
So i flashed the crazyflie like this https://www.bitcraze.io/documentation/r ... 20.02/dfu/.
After the flash i realised the lighthouse deck red light remaind on. Then i installed the newest crazyflie client and tried to flash again, since the lighthouse deck was still not working.

I flashed multiple times, because sometimes the crazyflie client would be stuck in the flashing process, because the lighthouse deck would not turn on again, when it would restart during the flashing process, so it would say 'updating deck' with no progress.
After multiple tries, it suddendly worked and the flashing process finised after it said updating deck. But after i restart the crazyflie it would still not work.
jjan3640
Beginner
Posts: 3
Joined: Tue Mar 30, 2021 4:18 am

Re: Lighthouse Deck Red and Blue LED Remaining On

Post by jjan3640 »

Thank you for the response.

I do have the most up to date cfclient and cflib installed using pip3 and have flashed the Crazyflie with the 2021.03 firmware however I'm still facing the same issue. During the flashing process the two progress bars say it is writing buffer to stm32 and nrf51 however this is the same whether the lighthouse deck is attached or not. Is there meant to be a seperate step for flashing the lighthouse deck?
jjan3640
Beginner
Posts: 3
Joined: Tue Mar 30, 2021 4:18 am

Re: Lighthouse Deck Red and Blue LED Remaining On

Post by jjan3640 »

The issue has seemed to be solved. I completely uninstalled the Crazyflie client and library and reinstalled it and then reflashed the Crazyflie drone. The correct LEDs are now shining and I am able to get accurate position data from the base stations.

Thank you for the help :D
kristoffer
Bitcraze
Posts: 427
Joined: Tue Jun 30, 2015 7:47 am

Re: Lighthouse Deck Red and Blue LED Remaining On

Post by kristoffer »

I'm glad it worked out!

Yes, it is important that the python lib is updated as well
Post Reply