Page 1 of 1

Crazyflie don't work

Posted: Thu Jun 14, 2018 1:00 pm
by gabrielfvds
Hello, my problem is:

I could not access crazyflie's bootloader mode, so I reinstalled the firmware using a ST LINK, now when I turn it on by pressing the ON / OFF button, only the M2 blue LED turns on.

Other problems:
Now I can not connect the crazyflie via Bluetooth

I use Linux, and VM

Re: Crazyflie don't work

Posted: Thu Jun 14, 2018 4:34 pm
by whoenig
Can you still get to the bootloader by the following method?:

1. Disconnect CF (battery/USB)
2. Press the button and *at the same time* connect the CF to power (battery or USB); Keep the button pressed for 3 seconds.
3. After 3 seconds, if successful, the two blue LEDs should blink.

Note that 2. can be a two-person-job.

Re: Crazyflie don't work

Posted: Fri Jun 22, 2018 1:51 am
by arix
I think you use stlink maybe only flash nrf.bin. I remember you also need bootloader.bin and other bin, but i forget......

Re: Crazyflie don't work

Posted: Wed Jun 27, 2018 1:44 pm
by gabrielfvds
Thank you all
I solved the problem doing the bootlooader DFU mode
I did

Code: Select all

sudo dfu-util -d 0483:df11 -a 0 -s 0x08004000 -D cflie.bin