Big Quad Issues

Discussions about all things Bitcraze
Post Reply
Nickle225
Beginner
Posts: 3
Joined: Tue Feb 09, 2021 9:27 am

Big Quad Issues

Post by Nickle225 »

Hi,

I recently built a larger drone using the big quad deck, but am having some issues getting the motors to run.

In my first attempt, I created a config.mk file and appended 'CFLAGS += -DENABLE_BQ_DECK'. When flashing this, and running it on the crazyflie, the ESCs kept beeping to indicate that they were not armed.

After digging through the forum, I noticed that a few other flags had to be set in the config file. See my full config.mk file below. After flashing this onto the crazyflie, the ESC's stop beeping (indicating that they are likely armed), but they do not spin. This is despite the 'idle' speed set in the config. The motors also didn't run when I ran a python script to take off. Do I need to arm the crazyflie or something?

I thought maybe the 400hz pwm was not compatible with the ESCs, so I also tried the one-shot configuration. When I ran this version, the ESCs never armed. So from my point of view, it looks like the ESCs work and are receiving a signal from the crazyflie, but nothing else is happening.

I feel like I am missing something, and any help would be greatly appreciated!

CONFIG.MK:
CFLAGS += -DCF_MASS=1.f
CFLAGS += -DENABLE_BQ_DECK
CFLAGS += -DSTART_DISARMED
CFLAGS += -DDEFAULT_IDLE_THRUST=5000
tobias
Bitcraze
Posts: 2234
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: Big Quad Issues

Post by tobias »

Hopefully during the fall we will develop much better Bolt and BigQuad support... :oops:

I think what is now missing is that you need to set the parameter system.forceArm to 1 so the motors will start spinning as a safety measure. The other option is to remove the CFLAGS += -DSTART_DISARMED flag.
Post Reply