LED's on Loco node won't turn on

All discussions related to the Loco Positioning system
Post Reply
Posts: 10
Joined: Wed Jul 08, 2020 3:04 pm

LED's on Loco node won't turn on

Post by linrs »

Hey everyone, earlier I had tried to power the Loco node using a crazyflie battery (plugged it into the debugger I believe on the side) but all that had happened was that the STM chip began to heat up rapidly so I then unplugged it. Afterwards, I tried plugging the Loco node normally into my computer through USB and now the only LED which is on is the blue led for power. I've tried reflashing the firmware and updating it with the lps tools but I haven't had any luck. I hope there is a solution to this issue

Thank you!
Posts: 700
Joined: Fri Jul 06, 2018 11:13 am

Re: LED's on Loco node won't turn on

Post by kimberly »

It seems like the STM is fried. Did you plug in the crazyflie battery directly into the white debug connector without any modification (like using a different male connector for the batteries). The pins count is also not similar as well.

It is unsure what happened but then it would have went around all the power regulations that are in place for the three power possibilities that we have on the bottom of the LPS node. The debug connector is absolutely not for powering.

I'm afraid that you fried your LPS node. There is no solution to this except for to replace the STM chip, but without good soldering tools and skills this will be impossible to do.
Post Reply