Page 1 of 1

One anchor doesn't work

Posted: Sun Jul 12, 2020 4:10 pm
by anomi

I just switched to tdoa mode with 8 anchors, I configured them with their Id from 0 to 7, but I have a problem with a single anchor. its LEDs do not flash like the others also it's not displayed on the cfclient, I configured it several times but always the same problem.

Could you help me to know where the problem comes from, thank you in advance.

Re: One anchor doesn't work

Posted: Mon Jul 13, 2020 9:50 am
by kimberly

Are none of the LEDs flashing or are only a few? Which ones are flashing specifically?

If all the LEDs are not on at all, then you might have to check your power supply. If the LEDs are on, then you might just need to reconfigure your LPS node with an micro USB cable to already have the right method that you usually use.

Re: One anchor doesn't work

Posted: Tue Jul 14, 2020 12:55 pm
by anomi

Thank you for your reply, I reconfigured the anchor several times I tried with several cables and all the ports on my computer. but I still have the same problem.

Here is a photo of the anchor after connecting the crazyflie with the other anchors:


Re: One anchor doesn't work

Posted: Tue Jul 14, 2020 2:46 pm
by kimberly
Could you please follow these instructions and copy past the configuration output here in the thread: ... el-config/

Which TDOA method are you trying out for your crazyflie? TDOA2 or TDOA3?

Re: One anchor doesn't work

Posted: Thu Jul 16, 2020 10:26 am
by anomi
I'm sorry for this delay, here is the configuration output from my anchor:

Code: Select all

SYSTEM	: CPU-ID: 460026000a514d5936333320
TEST	: Initializing pressure sensor ... [OK]
TEST	: Pressure sensor self-test ... [OK]
TEST	: EEPROM self-test ... [OK]
CONFIG	: EEPROM configuration read and verified
TEST	: Initialize UWB  ... [OK]
CONFIG	: Address is 0x7
CONFIG	: Mode is TDoA Anchor V2
CONFIG	: Tag mode anchor list (6): 0x01 0x02 0x03 0x04 0x05 0x06 
CONFIG	: Anchor position enabled: true
CONFIG	: Anchor position: 1.170000 0.000000 0.000000
CONFIG	: SmartPower enabled: True
CONFIG	: Force TX power: False
CONFIG	: Bitrate: normal
CONFIG	: Preamble: normal
SYSTEM	: Node started ...
SYSTEM	: Press 'h' for help.
For the mode i'am trying TDOA2 with 8 anchors

Re: One anchor doesn't work

Posted: Fri Jul 17, 2020 7:56 am
by kimberly
Hmmm... it seems like it is configured correct, since it is in the same range.

By the way, i saw on your picture that number 2 was written on there, but this node is configured as number 0x07 (so 7). Is that correct?

Also the tag mode anchor list is missing node 0x00, so it might be that you are looking at the wrong node that is malfunctioning.

Reflashing the mallfucntion node accoridng to the tutorial will also be something you can try then ( ... -the-nodes)

Re: One anchor doesn't work

Posted: Fri Jul 17, 2020 1:19 pm
by anomi
No I was not wrong on the anchors because I configured it with an id 7, I did all the steps indicated here: ... -the-nodes

For the ids I took from 0 to 7, I have all the anchors working well except the 7 the problem that it works at the beginning but after 10 seconds it disconnects from cfclient.

Re: One anchor doesn't work

Posted: Mon Jul 20, 2020 8:11 am
by kimberly
I am just reciting what I see on the on configuration output, since 0x00 is missing on that list. But okay, let see if this can be fixed.
  • Try to reflash the node would be the first to start
  • It might be that the power input is not sufficient. You should check by measuring if it is indeed between 5-12 V and 150 mAh at least. Be ware that if you have a very long cable, the output at the end might be less than you expect
Let us know if you tried this and if not, please contact so that we talk about a replacement.