Bad performance with new version of LPS and Crazflie

All discussions related to the Loco Positioning system
Post Reply
faria
Beginner
Posts: 12
Joined: Mon Jun 17, 2019 4:30 pm

Bad performance with new version of LPS and Crazflie

Post by faria » Thu Oct 17, 2019 2:01 pm

Hi all,

On the last week i updated my 3 Crazyflie and LPS (8 nodes) with the last version. After that i realized several tests (Swarm), but the results are not better.

So I realized individual tests with different versions (Sept and Fev). The Fev version i have better results. For example i have a better landing results with Fev version (after several tests to compare). Any reason? Anyone have this problem? Only me?

Best Regards
Faria



arnaud
Bitcraze
Posts: 2275
Joined: Tue Feb 06, 2007 12:36 pm

Re: Bad performance with new version of LPS and Crazflie

Post by arnaud » Mon Oct 21, 2019 11:35 am

I cannot think about any change in the LPS code that could have this kind of effect. I can think of a couple of things you could check and info that would be useful to locate the problem:

What API are you using to fly your Crazyflies? (ie. low level setpoints or high level commander, from ROS or using the Crazyflie Python lib?)

Have you tried to switch back-and-forth between version to make sure the problem is indeed with the version?

Have you tried to update only part of the system, for example only the Crazyflie or only the anchors, to find out where the problem could be?

faria
Beginner
Posts: 12
Joined: Mon Jun 17, 2019 4:30 pm

Re: Bad performance with new version of LPS and Crazflie

Post by faria » Tue Oct 22, 2019 8:56 am

Hi Thanks a lot your feedback,

I agree with you, i saw the fix bugs and the modifications are not influenced the stabilization

What API are you using to fly your Crazyflies? (ie. low level setpoints or high level commander, from ROS or using the Crazyflie Python lib?)
I am using Crazyflie Python Lib (Swarm)

Have you tried to switch back-and-forth between version to make sure the problem is indeed with the version?
Yes

Have you tried to update only part of the system, for example only the Crazyflie or only the anchors, to find out where the problem could be?
Yesterday i updated only the firmware of Loco Position Nodes and i maintain the firmware of Crazyflies (Fev2019), without issues.

I will realize others tests to validate.


BtW: I bought the flow deckV2 to improve my position (Z), another update.

faria
Beginner
Posts: 12
Joined: Mon Jun 17, 2019 4:30 pm

Re: Bad performance with new version of LPS and Crazflie

Post by faria » Tue Nov 19, 2019 2:46 pm

Hi All,

After some several hardware update i can realize a autonomous flight without problems with the last version of firmware.

I included Flow Deck V2, works very well (stable flight). Good Work CrazyFlie.

Thanks a lot.

Post Reply