Page 1 of 1

Modifying the loco positioning firmware

Posted: Sun Sep 08, 2019 12:53 pm
by nicuvlad94

My name is Vlad, I am an ETH Zurich master student and for the last task of my master thesis I have to use crazyflie (never used it before). I would need to modify the DW1000 driver to work with my custom anchors. The only thing that I need is to perform ranging with my anchors. I tried to make a new task - in a new file, where I also copied the necessary functions from "lpsTwrTag.c". So created a loop in my task which executes every 3 seconds, where I blink an led and I execute this:

However, it seems that after one cyce, the task halts because the led does not blink anymore. Do you have any idea why this happens? I mention that when I initialize the dw1000 with dwConfigure(dwm) it works.

Do you have any clue why this happens?

Thank you,

Re: Modifying the loco positioning firmware

Posted: Tue Sep 10, 2019 7:17 am
by tobias
Sounds interesting, please share more about you work :-). I'm guessing it gets stuck waiting for something, possibly a response from the dw1000?

Re: Modifying the loco positioning firmware

Posted: Thu Sep 12, 2019 3:22 pm
by jdiep
I am an ETH student as well and also modified the firmware for my master thesis. I had a similiar issue, but I solved it by changing the return value from MAX_TIMEOUT to an arbitrary integer. Maybe this helps?