Page 1 of 1

Wrong position estimate from drone using LPS [SOLVED]

Posted: Wed Jul 03, 2019 11:28 am
by frida
Hello. We are two students working on a crazyflie 2.1 this summer with the intent to test out autonomous flying of a drone. We have followed your guides up to this point, and we are currently testing out our drone with LPS. Our problem is that the drone seems to have a different perception of what one meter above ground is on different places of the room (differs maybe 50 cm). We have tested and ruled out the following:
  • Unbalanced propellers
  • Wrong distance between nodes
  • Different nodes having different modes (TWR vs. TDoA)
  • Error in the code (the error applies to both moving it around by hand (or something with a known height, like a chair) and with a code, like examples/
  • Old firmware on drone and/or nodes
The error is also present when looking at it in “loco positioning” in cf client, as it reports ground height (z = 0) to be 40 cm (z = 0.4 m) in some parts of the room, which leads us to believe that it is something wrong with one (or more) of the nodes (anchors), but we are not sure. Are there some tests we could run, or something we have totally forgotten to consider?

We use TWR with 8 nodes, and all the nodes are green in the crazyflie status-board. All the nodes are at least 0.15 m away from ground/walls and there are at least two meters distance between each node.

Note: The error is consistent, meaning that one meter is always correct (that is, actually one meter) in some parts of the room, and wrong on other parts (that is, maybe only 0.4 m above ground, when the reported height from the drone is 1 m)

Thank you in advance! :)

Re: Wrong position estimate from drone using LPS

Posted: Tue Jul 09, 2019 8:19 am
by kimberly
Hi Frida,

Sorry for the late response, but we are a bit understaffed now at the office since everybody is on a holiday now :)

Thanks for giving the experiment list, we can now rule out most of the problems hopefully.

Have you tried to reconfigure the system by going through the steps of ... the-system again? Have you checked the positions in the LPS tab of the CF client and provide a screenshot of that?

Re: Wrong position estimate from drone using LPS

Posted: Fri Jul 12, 2019 7:51 am
by frida
Hello Kimberly,

Thank you for your reply. We could not figure out the problem, but when we added the flow deck the drone were much more stable, so with the flow deck the problem seems to be gone. We are therefore going to just use the flow deck from now on to avoid the issue. Thank you anyways!