[SOLVED] Unable to change anchor TX power

All discussions related to the Loco Positioning system
Post Reply
Posts: 17
Joined: Fri Apr 29, 2016 1:53 pm

[SOLVED] Unable to change anchor TX power

Post by carlos.luis306 » Thu Oct 11, 2018 4:38 pm

Hi all,

I'm trying to run the script set_tx_power.py to play around with the transmission power of the anchors to see if I can get better localization with different settings.

The problem is that when I run the script it gets stuck at : "Connecting to radio://0/120/2M/E7E7E7EC05" (that's the address of the CF, verified through successful connection to the cfclient). Am I doing something wrong?

The whole command window looks like this:

sudo python3 set_tx_power.py 30
Sending anchor transmit power configuration to anchors (0 to 7) using radio://0/120/2M/E7E7E7EC05. Setting transmit power to 30dB. Anchors will resetwhen configured.
Connecting to radio://0/120/2M/E7E7E7EC05

I've tried running with and without sudo too, just in case. The result is the same in both cases.

Any guidance will be appreciated, thanks!

EDIT: I solved the issue by updating the firmware on the anchors to the latest on the master branch. My previous firmware was the release of January, so I think the script to change transmission power is not compatible with that firmware.

Posts: 2021
Joined: Tue Feb 06, 2007 12:36 pm

Re: [SOLVED] Unable to change anchor TX power

Post by arnaud » Wed Oct 17, 2018 8:19 am


Great that you solved your problem, thanks for updating us! Generally if you use a script from the git repos, make sure the firmware is updated to the same commit as the one you find the script in (ie. if you would checkout the January release tag, this script did not exist).

Post Reply