CF Not Powering On

Discussions and questions about the Crazyflie Nano Quadcopter
Post Reply
Posts: 14
Joined: Mon Nov 26, 2018 2:20 pm

CF Not Powering On

Post by HuzayfaaN »

Hi All,

I've been running some flights today on the Crazyflie and mid way through a flight it powered off and has since not powered back on. I have multiple different batteries and have tried the majority of them; non of which power the CF on. The batteries have been tested with my seconds CF and that seems to work fine. :(

I have also tried to power the CF using the USB cable, having connected it to a PC, although this too has proven unsuccessful.

Can I please ask what other tests I can conduct to determine what has gone wrong and the next steps. I would appreciate any help.

Posts: 2059
Joined: Mon Jan 28, 2013 7:17 pm
Location: Sweden

Re: CF Not Powering On

Post by tobias »

Sound like a hardware failure unfortunately. Can you send an email to and we will help you out.

My guess is that something failed within the power path, probably the power management chip.
Post Reply